


DIACARA 

WordPress Theme For Law Firm & Attorneys 

 

 

Thank you for purchasing Diacara!  

This documentation will guide you in building your dream business website with Diacara. Please read 

carefully for any questions or issues you may be experiencing and to leverage theme’s capabilities. If your 

issue isn’t solved in this documentation, feel free to ask in our support forum. 

 

Follow us on ThemeForest, Twitter, and Facebook for future projects and updates. 

We hope you enjoy building with our theme as much as we enjoyed developing it ☺ 

  

http://support.daffyhazan.com/
https://themeforest.net/user/dahz
https://twitter.com/Dahztheme
https://www.facebook.com/Dahztheme/


Theme Installation 

Diacara Theme Requirements 

To use this theme, you need to make certain first that your server and WordPress meet the theme’s 

requirements, including WordPress version 4.8+. Common issues such as white screen after theme 

installation, out of memory errors, or fail importing demo content are usually related to the server settings 

and excessively low PHP configuration limits. You can change them by yourself or contact your hosting 

provider and request the limits be increased to the following minimum:   

 file_get_contents() function should be enabled in the server configuration; 

 PHP version 7 or greater 

 MySQL version 5.6 or greater OR MariaDB version 10.0 or greater 

 OpenSSL system library: 1.0 version, or higher; 

 max_execution_time: 180, or greater; 

 memory_limit: 128M, or greater; 

 upload_max_filesize: 40M, or greater. 

Use the WordPress PHP info plugin to check your PHP configuration limits. 

Diacara Theme Packages 

After purchasing from ThemeForest, you need to enter the download section by navigating 

to ThemeForest > Your Account > Downloads where you can view all your purchases. Find Diacara theme 

on the list then select the installable WordPress file only option to download. If you prefer to download 

the whole package (all files & documentation), extract the package after downloading to get a single zip file 

titled diacara.zip (which is the WordPress theme file). 

 

https://wordpress.org/plugins/wordpress-php-info/


NOTE: If you get “The package could not be installed. The theme is missing the style.css stylesheet.” error 

message, it means you are not uploading the correct file. Please make sure you have extracted the zip file 

first to get the installable file in it. 

If you have downloaded the entire package, you will find the following files after extracting: 

 diacara.zip file, the theme file you will use to install on WordPress 

 Documentation folder 

 Diacara-child theme folder 

 

Installing The Theme 

There two options you can choose for installing the theme, but first make sure that your system meets the 

previously described requirements. 

Method 1 – WordPress admin dashboard 

1. Navigate to Appearance > Themes > Add New. 

2. Click Upload Theme button then select the Diacara.zip file (the installable WordPress file only or 

the zip file you get after extracting the entire package from ThemeForest). 

 

 

3. Press the Install Now button to start installing the theme. 

 

 

4. After uploading, you need to activate the theme. 



 

 

5. Use the Diacara Setup Wizard to continue the installation. 

 

The Setup Wizard is a multi-step wizard that enables you to go back and forth one page at a time. You can 

skip some of the steps, but we recommend entering all the required information before proceeding to the 

next step. 

NOTE: Theme activation and installation of required plugins must be done. 

 

 



Method 2 – FTP 

Using your FTP program, extract the Diacara.zip file and upload the extracted folder. 

1. Connect to your server via FTP software. 

2. Extract Diacara.zip file and upload the extracted Diacara folder to /wp-content/themes/ folder on 

your server. 

3. Go to your WordPress dashboard then navigate to Appearance > Themes to activate Diacara. 

 

 

Child Theme 

When you update the theme, any changes you have made to css and php files will be gone. To avoid re-

applying your changes after updating, you can use child theme of Diacara. 

A child theme is a theme that inherits the functionality and styling of another theme, called the parent 

theme. Child themes are the recommended way of modifying an existing theme as the changes in it won’t 

be affected by the updates. We include a child theme package ready that you can get within the main 

download folder named Diacara-child. Upload the file into the /wp-content/themes/ folder. 

NOTE: Child theme can be activated using Diacara Setup Wizard. 

 



Demo Content 

Demo contents are provided to make settings up your site easier and faster. There are 2 ways to import 

the demo content: 

 One-click installation using the Setup Wizard 

 Default import of .xml files 

One-click installation using the Setup Wizard 

We recommend you to use this method to avoid any issues with the theme’s installation. 

 

 

 

 

 

 



 

 

 

Default .xml files import 

If you don't want to import all our dummy content because you just need separate pages from our demo, 

or if you can't use one-click import according to the server settings, import of .xml files is your best option. 

We’ve included all the demo versions and additional pages in the Import to XML Files folder of the theme’s 

package, where you'll be able to see the theme’s .xml files and Revolution Slider archive files. Diacara 

Customizer can also be imported by copying the text file and pasting its content into the Import from File 

field on the Import/Export tab in Diacara Customizer (within Appearance > Customize > Backup > Export 

Import > Import Customizer).  



Theme Settings 

You can configure Diacara settings through the Customizer and Metabox. 

Diacara Customizer 

To access the customizer, from your dashboard navigate to Appearance > Customize where the settings 

are organized into logical tabbed sections. These are the global options for your website. If you want to set 

specific options for a specific page, post, or portfolio, set them in Metabox settings which will override the 

general setting. You can locate the metabox in every page/post/portfolio. 

 

General Section 

You can set general options for your site in this section: Global (ex: Lazy Load, Sticky Sidebar, Google 

Analytic), Share Button, 404 Page, Layout, Breadcrumbs, Transition, Newsletter, Merge Script, and Custom 

Code. 

 

Social Account Section 

Show list of social icons which style is set on social icon section in header settings. To set up your social 

account go to Appearance > Customize > Social Account. 

 

Header Section  

There are many possibilities in creating your header. You can easily use the drag and drop builder in 

Diacara to create your website header. To begin modifying, navigate to Appearance > Customize > Header 

on your admin panel. There you can set up all elements in the header with the live preview on the right 



side. You can also set these header elements for your site in this section: Logo & Site Identity, Header 

Before & After, Header Section 1, Header Section 2, Header Section 3, Sticky Header, Navigation, 

Dropdown, Header Transparent, Off Canvas, Social Icon, Search, Mobile Element, Contact, Newsletter, and 

Button Header. 

 

 

When you go to the header settings, the drag and drop builder will appear on the bottom of the live 

preview. It allows you to drag and drop elements into header areas, which is divided into three section. 

Sections in the builder represent each area in the header while the columns represent the position, 

depends on the layout you choose (e.g. in general, if you drop an element at the right side of the first 

section, the element will be displayed at the right side of your top bar).  

The placement order in a section also represents the position (stack) of elements. 

 Section 1 - First row: to drag and drop elements for the top bar. 

 Section 2 - Second row: to drag and drop elements for the main header area. 

 Section 3 - Third row: to drag and drop elements for the bottom of the header 



 

NOTE: Clicking the blue gear symbol in each tab section or element will take you directly to the page 

settings of the selected section/element. You can modify the selected section or element quickly without 

having to go to its section in header settings manually. 

 

 

Footer Section  

The same as building your header, you can easily use the drag and drop builder to create the website 

footer. Navigate to Appearance > Customize > Footer on your admin panel to set up your footer. You can 

set these footer elements for your site in this section: Footer Element, Footer Before & After, Footer 

Section 1, Footer Section 2, Footer Section 3, and Social Icon. 

 



 

When you go to the footer settings, the drag and drop builder will appear on the top of the live preview. It 

allows you to drag and drop elements into footer areas, which is divided into three section. The Sections in 

the builder represent each area in the footer while the columns represent the position, depends on the 

layout you choose. 

The placement order in a section also represents the position (stack) of elements. 

 Section 1: to drag and drop elements on the top of footer area, may consist of every footer 

element. 

 Section 2: to drag and drop elements on the bottom of footer area 

 Section 3: additional row showing the pre-built elements that are not in use. You can drop 

elements you do not want to use here or drag elements to place it in the footer. 

 

NOTE: The number of columns depends on the chosen footer layout. Every time you change the footer 

layout, you need to re-assign the elements into the builder. 



The builder provides the shortcut to modify each element using Edit button for each element. The button 

will take you directly to the page settings of the element without having to go to its section in footer or 

widget settings manually. 

 

Color Section  

These options allow you to set custom colors for these elements in your site: General Color, Button Color, 

and Transparent Element Color. 

 

Blog Section  

You can set up these options in this section – Archive Layout, Blog Template, Single Post Layout, and 

Featured Area. 

 

Portfolio Section  

You can set up these options in this section – Portfolio Archive & Portfolio Single. 

 

WooCommerce Section  

This section will appear if you install WooCommerce plugin. You can find the e-commerce settings of our 

theme such as Product Catalog, Shop, and Single Product settings. 

 

Page Section  

You can set up page layout globally in this section. 

 

Typography Section  

Fonts in Diacara are customizable. Everything you need to adjust your website fonts can be found in 

Appearance > Customize > Typography. Select the source of the font you use, either Google Font or Adobe 

Typekit. 

 Main Font: applied to heading, widget title, and share text. 

 Secondary Font: applied to body elements, such as body text and post meta. 

 Variant: font weight. 



 Subset: alphabet type. 

For main navigation, header menu, drop-down menu, and button, you can choose which font to use 

between Main Font & Secondary Font. 

 

Backup Section  

This section enables you to backup your setting from Header, Footer, and Customizer Settings.  

 

 

 

 

Diacara Metabox 

Besides selecting layout generally for posts or pages, you can manage the appearance of a specific post or 

page when creating one. Diacara includes custom metabox in each post or page editor that allows you to 

modify the layout of the current page or post you create. You can disable sidebar, disable footer, and many 

more. You can find our Dahz Setting custom metabox when creating a post, page, or portfolio right under 

the WYSIWYG content editor. 

The customization you have made in Dahz Setting will only affect the selected post or page. In general, the 

layout settings automatically follow the default setting you have set in live customizer (within Appearance 

> Customize). 

Header 

In all Metabox setting, you can find Header tab section which allows you to modify the layout elements in 

header such as header preset and sticky header or add elements to your header; before and after header. 

Options in Header section are varied for each page or post. You can also override the main menu only for 

this page (make sure before overriding the main menu, you have been assigned default main menu) 

 



 

 

Page Title 

Page Title tab section can only be found when you’re creating or editing page & portfolio. It allows you to 

change the style of page title each page & portfolio. 

 

 



Content 

Options in Content section are varied for each page or post. For example, in a post you can see the options 

for Sidebar Layout and activate Feature Area Slider while in a page you can select the sidebar and activate 

the option of Section Scroller. 

 

 

Footer 

In all Metabox settings, you can find Footer tab section which allows you to modify the layout elements 

such as footer preset and disable footer or add elements to your footer; before and after footer. 

 

 



Portfolio 

Portfolio tab section can only be found in the Dahz Setting if choose portfolio template while creating a 

page. It allows you to change the portfolio layout on the archive. 

 

  



Menu Setup 

Diacara supports the custom WordPress menus. Custom menus may contain links to pages, categories, 

custom links or other content types. If you want to add special features to the menu like posts and posts 

categories, portfolio categories, classes for links, etc., click on the Screen Options button in the upper right 

corner, where you'll be able to choose much more menu item options.  

There is no limit for the number of menus you can create. Diacara theme features these 3 menu locations: 

 Primary menu – This menu will be displayed in the main menu position, can be used as megamenu 

 Secondary menu – This menu will be displayed in the secondary menu position, usually used as top 

bar menu 

 Footer menu - This menu will be displayed in the footer 

 

In the section Manage Locations, you can choose which menu to associate with each location. 

 

To create a new menu, navigate to the Dashboard > Appearance > Menus page and click on create a new 

menu link. Then, you can add pages, posts and custom links from blocks located on the left. When you 

have your menu items arranged in the order you want within Menu Structure, click on Save Menu. 

 

 

  



Theme Customization 

Sticky Sidebar 

To enable or disable sticky sidebar, navigate to Appearance > Customize > General > Global. 

Back to Top 

To enable or disable back to top button, navigate to Appearance > Customize > General > Global. 

Pages 404 

Diacara provides a default layout for 404 page, but you may also customize the layout by navigating to 

Appearance > Customize > General > 404 Page. 

 

 

Modifying Page Width and Background Color & Image 

To customize the general layout of your website, navigate to Appearance > Customize > General > Layout. 

 

Custom Code 

You can easily add custom code to your website in Diacara. Simply head to Appearance > Customize > 

General > Custom Code, then you will see editor buttons for: 

 Custom CSS: Add some CSS by adding it to this editor. 

 Custom Javascript Header: Add JavaScript, any code that you add here will be moved to the 

header. 

 Custom Javascript Footer: Add JavaScript, any code that you add here will be moved to the footer. 

 



Breadcrumbs 

You can enable/disable breadcrumbs from Appearance > Customize > General > Breadcrumbs. 

 

Google Analytic 

To add Google Analytics code, head to Appearance > Customize > General > Global then input the code in 

Google Analytic ID field. 

 

Lazyload 

You can enable/disable lazyload from Appearance > Customize > General > Global. 

 

Social Account 

To set up links to your social account, add the URL of your account in Appearance > Customize > Social 

Account. 

 To change the order of social icon displays, you can drag and drop the account below the Social 

Account form. 

 To display your social icon on the top bar or footer area, you can drag and drop Social Icon element 

in header or footer builder. 

 

Social Sharing Option 

You can add share buttons on a single post, single page, and portfolio share by enabling the option from 

Appearance > Customize > General > Share. The available sharing buttons are for Facebook, Twitter, 

Pinterest, Mail, Tumblr, VKontakte, Whatsapp, and Google Plus. 

 

Logo & Favicon 

To upload your logo and favicon, navigate to Appearance > Customize > Header > Logo & Site Identity. 



 

Changing Logo 

In Diacara, you need to upload 4 types of logo which are the default logo, light logo for transparent header, 

dark logo for transparent header, and sticky logo. You also need to upload the retina version for each type. 

1. Upload your logo for all versions (default, light, dark, sticky) by clicking on select image button 

2. Browse your logo on the ‘Media Library’ or upload a new one, then click choose image 

3. Click save & publish to save your change or change file to choose another logo image. 

For retina logo, you need to upload another image with twice the size of your “normal” logo. You also need 

to make sure that the file have the same logo name and add @2x before file extension. For example, if 

your logo file name is “mylogo.png” (resolution 200 x 20px), you should upload another named 

“mylogo@2x.png” (resolution 400 x 40px) for the retina logo. 

NOTE: Diacara’s default logo in the demo is set at 160 x 36 px. 



 

Changing Address Bar Icon/Favicon 

Navigate to Appearance > Customize > Header > Logo & 

Site Identity then scroll down to the Site Icon Logo section.  

1. Click on select image button to upload your 

favicon logo.  

2. Browse your favicon on the ‘Media Library’ or 

upload a new one, then click choose image.  

3. Click save & publish to save your change or 

change file to choose another logo image. 

NOTE: Icons must be square, and the minimum resolution 

is 512 pixels wide and tall. 

 

Mobile Logo 

Alternatively, you can upload another version of your logo to be used in mobile layout. To upload the 

mobile logo, head to Appearance > Customize > Mobile Element. 

 

Site Title & Tagline 

You can also set up your site title and tagline from the Appearance > Customize > Header > Logo & Site 

Identity section. Enter the site title and tagline in the available fields.  

 

Sticky Header 

The option you're looking for can be found by navigating to Appearance > Customize > Header > Sticky 

Header section.  



 

 

Adding Element Before and After Header 

You can set the Content Block that has been created as element before / after header by navigating to 

Appearance > Customize > Header > Header Before & After section.  

 

Customizing Header 

To customize the display of header area, on your WordPress dashboard navigate to Appearance > 

Customize > Header > Header Section 1 / Header Section 2 / Header Section 3 as you have created in the 

header builder. There you can modify the color, size, and upload custom image for your main header 

background of each section. 

 

Customizing Mobile Header 

To customize header’s appearance on mobile, please go to Appearance > Customize > Header > Mobile 

Element. 



 

 

Customizing Header Transparent 

To customize header transparency, go to Appearance > Customize > Header > Header Transparent. In this 

section you can customize light and dark color schemes for the header elements. Before you custom the 

color, you need to go to a specific page which has the light/dark header transparent manually. 

 

Customizing Dropdown Display 

To customize the display of dropdown menu in main navigation, go to Appearance > Customize > Header > 

Dropdown, then set the display to your liking. 

 

Customizing Navigation Style & Size 

To customize the display of navigation menu in main navigation, go to Appearance > Customize > Header > 

Navigation Size, then set the style and font-size to your liking. 

 

Off Canvas Element 

The option you're looking for can be found by navigating to Appearance > Customize > Header > Off 

Canvas Element section. Set the Content Block as element off canvas. 



 

 

 

Pop Up Newsletter 

Diacara features MailChimp for WordPress plugin to create newsletter signup form. The signup form can 

be displayed in the widget area and newsletter pop-up of your website. To add a MailChimp newsletter 

form, you need to create a MailChimp account first if you don’t have one. Install and activate the plugin, 

and then set up your signup form. 

MailChimp Setting 

1. After installing and activating the plugin, go to MailChimp for WP > MailChimp section from your 

dashboard. 

2. Add your MailChimp API key (use Get your API key here link to obtain your key) then click Save 

Changes. 

 

3. Go to MailChimp for WP > Forms, check your list for ‘Lists this form subscribes to’ option to set 

which list to use for subscription on MailChimp. 

4. Customize the form to your liking, then click Save Changes. You may use the field generator for the 

easiest way in creating form 



5. Copy the shortcode at the bottom of form setting to display this form inside a post, page or text 

widget; next we will try to create the form in the widget area. 

 

6. Go to Appearance > Customize > Widget. 

7. Choose an available widget area to input the form, then add ‘MailChimp Sign-Up Form’ widget 

into it. 

8. Paste the shortcode into the box. 

9. Save & publish 

 

TIP: You may also display the link for signing up as an element in header builder, and the setting can be 

found in Appearance > Customize > Header > Newsletter. 

Popup Newsletter Settings 

After setting up the MailChimp form, you can use the shortcode to create pop-up signup form. 

1. Go to Appearance > Customize > General > Newsletter. 

2. Enable the newsletter pop-up option. 

3. Paste the MailChimp shortcode in the Newsletter Form. 

4. Fill in the heading and text for the pop-up form. 

5. Select the interval when you want the pop-up form appears. 

6. Select a style for the pop-up layout. 

7. Click Save & Publish. 

Alternatively, you can use Modal Pop-up Shortcode in WPBakery Builder to create pop-up newsletter 

 

NOTE: If you can’t directly see your customization on the live customizer, you need to Save & Publish it 

first. 

 



 

Contact Form 

NOTE: Be sure that you have installed and activated the Contact Form 7 plugin.  

Creating Form  

1. Navigate to WordPress Dashboard > Contact > Add New then simply click Add New button. 

2. Make sure the form elements & email information look correct, then click Save button. 

Creating Contact Page  

1. Create a new ‘Contact Us’ page and add it to your navigation menu if you have not already done 

so.  

2. Copy and paste the generated contact form shortcode (see the screenshot below) into the text box 

on the create/edit page screen. And contact form will appear when the page is published.  

 

 

 

 

TIP: You can input contact form as one of your page element using Contact Form 7 shortcode in WPBakery 

Page Builder.

 

 

 

 

 

  



Post Type & Page Template 

Post Type Blog 

Diacara provides 4 different post formats: standard, video, gallery, and audio.  

Creating A Blog Post 

To create a blog post, from your WordPress dashboard go to Posts > Add New. You need to choose 

what format your post is from the ‘Format’ box on the right side then insert the necessary info. 

Scroll down to configure other settings within metabox. 

Blog Page Setup 

To display your blog posts, you need to create a blog page first  

1. Go to Pages > Add New 

2. Enter the title for the page such as ‘Blog’  

Alternatively, you can use content block shortcode to generate the page 

3. Click on Publish button 

4. Go to Appearance > Customize > Homepage Settings 

5. Select the page to be assigned as Posts Page 

 

Post Type Portfolio 

Diacara includes a built-in custom post type for the portfolio that makes sharing your works easier 

including explanation of your practice area. You can use the Portfolio feature after installing and 

activating Diacara Portfolio plugin. 

 



Creating A Portfolio Post 

To create a portfolio post, navigate to Portfolio > Add New. We recommend you to use WPBakery 

Page Builder in creating portfolio post. Click on the Backend Editor button to change WYSIWYG 

editor into WPBakery builder. Scroll down to configure other settings within metabox. 

Portfolio Page Setup 

To display your portfolio posts, you need to create a portfolio page first as the portfolio archive 

page. 

1. Go to Pages > Add New 

2. Enter the title for the page such as ‘Portfolio’ 

3. From the Template drop-down menu, choose Portfolio Template 

4. If needed, setup your portfolio layout from Portfolio Metabox setting tab 

5. Click on Publish button 

 

After that, you can assign portfolio page within Appearance > Menu as a navigation. You can also use 

Portfolio shortcodes to display portfolio list as an element on your page. 

 

 

  



Post Type Content Block 

The Content Block post type (Dashboard > Content Block) let you create "HTML Blocks" that can be 

inserted into pages, widgets, metabox and customizer using generated shortcodes.   

An example could be to create the content block as a "Who We Are" page and insert it to the header 

builder with a shortcode like [dahz-block id="who-we-are"]. 

 

 

 

  



Page Template Blank 

Blank Page template is availabe to build pages without showing a header or footer. This template is 

perfect for creating a landing page design and pages such as maintenance mode or coming soon on 

your website. You can use the same page options and elements for content. 

 

 

 

 

 

 

 

  



Widget Area 

There are 5 default widget areas you can activate to add your own content and functionality within 

Appearance > Widgets. 

 Sidebar 

The default sidebar visible on blog and pages with sidebar template. 

 Footer Area (1, 2, 3, 4) 

Add the content you want to display in the footer. Only visible if widget is added. 

 

 

 

Diacara has 8 different custom widgets to choose: 

 Content Block Widget 

 Dahz About Me 

 Dahz Address 

 Dahz Post Categories 

 Dahz Recent Posts 

 Dahz Social Media 

 Dahz Opening Hours 

 Widget Portfolio 

 

  



WPBakery Page Builder (formerly Visual Composer) 

Diacara uses customized WPBakery Page Builder to help you customizing your pages or creating 

complex layouts within minutes. You can change the WYSIWYG editor (WordPress default editor) 

into WPBakery editor for creating posts or pages. You can add many elements and row in your post 

or page including Diacara’s own shortcodes. 

 

For more detail documentation of WPBakery Page Builder, please check WPBakery Page Builder 

Official Guide and WPBakery Video Tutorials. 

 

 

 

WooCommerce 

Diacara is fully compatible with WooCommerce. If you want to make a shop section in your website 

for selling or affiliating, simply install the WooCommerce plugin. 

For more detailed documentation about WooCommerce, please check WooCommerce Official Guide 

and WooCommerce Video Tutorials. 

  

https://kb.wpbakery.com/docs/getting-started/
https://kb.wpbakery.com/docs/getting-started/
https://wpbakery.com/video-tutorials/
https://docs.woocommerce.com/
https://woocommerce.com/videos/


Theme Shortcode 

Diacara provides custom elements (shortcodes) in addition to WPBakery Page Builder elements. 

Select the Dahz tab, then you can see the list of custom shortcodes you can add to post or page 

content. 

Animated Text 

Use Animated Text shortcode to create text with animation whose speed can be adjusted to your 

website’s need. Not only animated text, this shortcode can also be used to create animated text with 

your preferred background image. 

To create animated text: 

1. Enter the text you want to display  

2. Choose Text Style, then you will see new options. 

3. Select one from the new options, either Animated Text or Animated Text With Image 

Background.  

a. Animated Text: You can change the settings of the text 

b. Animated Text With Image Background: You can upload an image as the background of 

the text. You can also set the color of the text inside the image and the text outside the 

image. 

4. Set the duration of the animation. 

  



Accordion 

Accordion shortcode enables you to add accordion drop-downs to your posts or pages such as FAQ 

page. 

To create accordion: 

1. Click Edit Accordion button (pencil icon in blue toolbar) to set up the style of accordion 

 

 

2. Select an icon style to use 

3. Check Allow Multiple Open Items box 

setting to allow opening several 

sections at the same time 

4. Check Allow All Items To Be Closed box 

setting to allow closing all sections at 

the same time 

5. Set the element tag for the title 

6. Select tag element for the title 

7. Check Custom Font Size box to adjust 

the title font 

8. Input the number of active section 

9. Set the color for active & inactive 

section, and the border 

10. Save changes. 

 

 

 

 

 

 



After creating the accordion, now you can set up the display for each section with its content. 

To configure the display: 

1. Click Edit Section button (pencil icon in orange toolbar) to set up the style of the section 

 

2. Enter the section title 

3. Input a section ID 

4. Select a color for title 

background 

5. Check “Add icon” box to add icon 

next to the section title 

6. Save changes 

 

 

 

 

 

To set up the content of the section: 

1. Click icon “+” to input the content using available shortcodes into the section 

 

 



2. Choose a shortcode to use to input the content and configure it according to the shortcode 

setting 

 

 

3. Repeat the steps by clicking icon “+” first to add another section 

 

 

 

  



Banner 

Use Banner shortcode either image, video, or multiple button to create your banner. You can read 

the w3school guide to help you in creating the banner height and padding 

Image Banner 

You can display an image to create a banner and redirect visitors to another link when clicked. Select 

the Image Banner shortcode then simply upload image(s) to display and input the link. Custom the 

element to your liking. 

Video Banner 

With Video Banner shortcode you can create an image banner that will turn into a playing video 

when you hover on it. Simply upload the image, add the title, title URL, caption and video URL. You 

can custom the color for the title, caption, and different display on mobile as well. 

http://www.w3schools.com/css/css_padding.asp


Multiple Button Banner 

You can use Multiple Button Banner shortcode if you want to create a banner with more than one 

button. 

 

 

  



Cascading Image 

Use Cascading Image shortcode to create an overlapping image. You can set the animation effect, 

position, shadow, etc. from the shortcode setting.  

Every layer you have created can be used to display a solid color for emphasizing the image on the 

top of it.  

 

To create an overlapping image: 

1. Set duration of the animation 

2. Select the shadow type for the uploaded image 

3. Set the alignment for the cascading image 

4. Upload image you want to display in Image tab 

 



Custom Heading 

Use Custom Heading shortcode to 

create custom styles of the page title. 

You can set the level of heading, use 

gradient style, or simply adjust the 

size of the title. 

 

 

 

  



Category Showcase 

You can use Brand / Category Showcase shortcode for displaying 

categories you have using grid or masonry layout. Before using the 

shortcode, you need to input categories for your portfolio or blog. 

You can set up the style and animation for the selected items 

within style & animation tab. 

General Setting 

1. Select the loop feed type you want to display (post or 

portfolio) 

2. Choose the layout style you want: 

a. If you choose style grid, you can select categories from 

your selected post type to display 

b. If you choose style masonry, You can select categories 

and also the display size for each category item 

3. You can specify the space size between the items you 

have selected in px 

 

Styling Setting 

1. Select a style for the showcase 

2. Set the hover effect along with the shadow style 

3. Choose a main color for your text/category title  

4. Choose a color for your text/category title when on hover 

5. Select an overlay color for the items when on hover 

6. Save changes 

 

 

TIP: You can also set different number of categories in one row for 

phone and tablet display within Settings tab. 

 

 

 

  



Countdown 

You can easily create a countdown timer to be displayed on your posts or page using the Count 

Down shortcode. 

Simply fill the date & time for the countdown, the select the element of it to be displayed (days, 

hours, minutes, and second) and leave it blank if you want to display the element.  

Within the Styling tab, set up style of countdown to use, along with colors and typography. 

 

 



Flip Box 

You can use Flip Box shortcode to display 

information on your website in a box with flip 

animation. When the box on hover, you can see 

the transition to display another content on the 

back side. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Map Location (Google Maps) 

You can show location map using Google Maps shortcode. To use this shortcode, please generate 

your Google Map API Key first, then set up the map setting for your location by entering the latitude 

and longitude of your location. You can also upload your custom marker icon within Design tab 

section. 

 

 

 

 

  



Gallery 

Image Gallery shortcode allows you to display your image 

collection in grid or slide layout. 

 

1. Select a layout you want to use 

2. Set the number of columns 

3. Define the action when the image in gallery is clicked 

4. Select the hover effect and hover type display 

5. If needed, you can also set up the column gap and 

shadow effect. 

 

In the Images tabs, you can set the ratio of images 

displayed in gallery, for example 1:1. 

 

 

  



Icon 

There are two icon shortcodes you can use: Icon Box and Icon List. Icon Box shortcode allows you to 

create a box with an icon and its description, while Icon List will display the icons and their 

description in a list form without a box. 

 

 

 



Milestone Counter 

Milestone Counter shortcode is what you need to 

show company milestone or highlight statistic data 

with animation. 

To create milestone element: 

1. Input the number in the milestone counter 

2. Set the font to style to primary font if you want 

to inherit the default font setting of your 

website. Otherwise, set it up in Styling tab. 

3. If needed, select the prefix symbol for the 

number along with its display position and 

alignment 

4. Input the title and subtitle of the milestone 

number 

5. Set the alignment for milestone display 

 

 

 

  



Modal Popup 

Use Modal Popup shortcode to display additional 

content on site page with pop-up. This way you don’t 

have to worry if the space on the page isn’t enough to 

display your additional content. 

General Settings 

1. Select a modal style 

2. Check “Enable Modal Title” to display heading 

then input the modal title 

3. Select a color for modal heading background 

4. Select a color for modal heading text 

5. Select a color for the border 

6. Set the modal size 

7. Select a color for content background  

8. Check “Full Modal” box to display the content 

in fullwidth mode (without padding) 

 

Button Options 

1. Enter the label of the button 

2. Select a style to display the button 

3. Set the default color for the button and its label 

along with the color when button/label on hover 

4. Adjust the button size in px 

5. Adjust the border radius in px 

6. Check “Use Icon” box to add icon next to the 

button label 

7. Check “Enable Fullwidth” box to display fullwidth 

button 

Modal Content 

In this General tab you can enter the content in the WYSIWYG editor. Click Save Changes after 

everything is set up. 



Pie Chart 

To add progress bar in circle form, use Pie Chart shortcode into your page content. Add the label for 

the chart, input the value and its unit then set the color elements. You can also adjust the thickness 

for the chart. 

 

 

 

Progress Bar 

Progress Bar shortcode allows you to create a standard horizontal progress bar. Simply add title and 

value for a bar and set the color element of it then set the unit of the value like percentage (%). 

 



Pricing Plan 

You can create pricing plan section in your page by using Pricing Label and Pricing Table shortcode. 

Pricing Table shortcode allows you to create each type of the plan while the Pricing Table will help 

you create the list of the feature when making a comparison between the pricing plans (yes/no of 

feature availability in the plan). 

Pricing Table 

General Settings 

1. Add title and subtitle for the pricing plan type 

2. Set the price by inputting the currency symbol 

and price value 

3. Set the the type of recurring fee 

4. Enter brief description of the plan 

5. If you want to use an icon, check the Use Icon 

box. You can upload your own icon. 

 

Contents 

In Contents tab you can enter the content of the plan, 

for example list of the features of the plan or yes/no 

symbol for feature comparison. 

 

Button 

Configure the call-to-action button of the plan in Button 

tab. 

 

Styling 

If you want to customize the body such as font size or 

title tag, you can do it in the Styling tab. 

 

 



Pricing Label 

If you want to create the feature availability list, you can use this shortcode. Simply enter the label 

title then move to Content tab to input the list. 

 

 

 

 

 

 

 

  



Post  

To display posts on your page, you can use Post Slider, Post List, Post Tabs, or Post Grid shortcode 

and add it to the page content based on the layout style you like.  

NOTE: If you choose to filter posts by Post ID, please input the ID of every post you want to include. 

To get the ID, go to Posts > All Posts then hover on the title of post so you can see the unique URL at 

the left bottom of your screen. For instance, you will see http://yoursite.com/wp-

admin/post.php?post=109&action=edit; then what you need to input in ‘Post IDs’ box is 109. 

Post Slider 

You can create a carousel of display images linked to your posts with Post Slider shortcode. Choose 

the posts to display based on the category, post ID, or recent posts and select one of the layout 

options to display them in the slider. 

 

 

Post Tabs 

Post Tabs shortcode allows you to display your posts in tabbed layout as an element of your page 

content that usually appear as a widget in the sidebar. This way, you can display more posts based 

on categories so that people can easily see the collection of posts of yours. 



 

Post List 

This shortcode helps you to display a list of your posts as an element of your page content. Choose 

which posts you want to assign and the style to display the text with the image. 

 

 

Post Grid 

This shortcode helps you to display images which link to posts in a grid layout as an element of your 

page content. Choose which post you want to assign and the style to display the text with the image. 



  



Portfolio 

To display portfolio posts on your page, you can use Portfolio Slider, Portfolio Tabs, or Portfolio Grid 

shortcode to the page content based on the layout style you like.  

NOTE: If you choose to filter posts by Post ID, please input the ID of every portfolio post you want to 

include. 

To get the ID, go to Portfolio > All Portfolio then hover on the title of portfolio post so you can see 

the unique URL at the left bottom of your screen. For instance, you will see http://yoursite.com/wp-

admin/portfolio.php?post=49&action=edit; then what you need to input in ‘Post IDs’ box is 49. 

Portfolio Slider 

You can create a carousel displaying your works with Portfolio Slider shortcode. Choose portfolio 

posts to display based on the category, portfolio post ID, or recent portfolios and select one of the 

layout options to display them in the slider. 

 

 

Portfolio List 

This shortcode helps you to display a list of your portfolios as an element of your page content. 

Choose which portfolio posts you want to assign and the style to display the text with the image. 



 

Portfolio Tabs 

Portfolio Tabs shortcode allows you to display your posts in tabbed layout as an element of your 

page content that usually appear as a widget in the sidebar. This way you can display more portfolio 

posts based on categories so that people can easily see your works. 

 

 

 

 

 

 

 



Social Media 

Use Social Media shortcode to display social 

icons linked to your account. You can set 

how all of your social accounts will be 

displayed. 

1. Select a style to display social icons 

2. Set the social icon size 

3. Select an alignment style 

4. Set the icon color if you want 

5. Save changes 

 

 

 

 

 

 

 

 

 

 

 

  



Slider 

Slider shortcode is useful to create a slider that contains customized contents using WPBakery Page 

Builder. For example, you can create a slider which consists of multiple flipboxes explaining all your 

service types. 

 

 

To use the shortcode: 

1. Choose Slider shortcode from the element list. 

2. If needed, click the slider settings to set the number of column displayed in one slide for each 

device. 

 

 

 



 

3. Click the + button of the section or in the row to input a shortcode for the first content. 

 

 

4. Move to other section to input another shortcode or you can simply clone the section you have 

created to make minor modification of the slider content. 

 

  



Split Slider 

Split Slider shortcode allows you to display two contents at the same time by splitting the screen 

area for each content as left and right content. You can insert another shortcode in creating the 

content both in the left side and the right side. 

1. Add Split Slider shortcode, then set the style for the dots of slider.  

2. Click the + button inside the Split Slider column. 

 

3. Select the side you want to assign the content, e.g. Split Slider Left. 

 

4. Click the + button inside the Split Slider Left column. 

 

5. Click the Split Slider Item option. 

6. Select the background color, then click Save Changes. 

 



7. Click the + button inside the split slider item column. 

 

8. Add element you want for the split slider content. If you want to add another content, 

select the + button to add split slider item. 

 

9. Repeat the same step for the other side (Split Slider Right). 

NOTE: If you want to use split slider, the header setting should be set as transparent header and 

don’t add other content after it. If you don’t want to show the header, simply select blank page 

template. 

  



Tabs 

Use Tabs shortcode to add tabbed content on your post or pages. 

To create a tab: 

1. Click Edit Tabs button (pencil icon in blue toolbar) to configure the tabs 

 

2. Select an alignment style 

3. Input the number of active section 

4. Check “Stretch Tabs” box to stretch the tabs 

5. Select a tag element for the tab title 

6. Set the title size in px 

7. Select title color 

8. Select a color for active title 

9. Select background color 

10. Select a color for active background 

11. Save changes 

 

 

 

 

 

 

 

 

 

 

 

 

 



After creating the tab, now you can set up the display for each section with its content. 

To configure the display: 

1. Click Edit Section button (pencil icon in orange toolbar) to set up the style of the section 

 

2. Enter the section title 

3. Check “Add Icon” box to add icon next to 

the section title 

4. Check “Active” box to show the section 

when the page loads 

5. Check “Full Size Content” box to display 

content in fullwidth (without padding) 

6. Select section background color 

7. Save changes 

 

 

 

 

 

 

To set up the content of the section: 

1. Click icon “+” to input the content using available shortcodes into the section 



2. Choose a shortcode to use to input the content and configure it according to the shortcode 

setting 

 

 

3. Repeat the steps by clicking icon “+” first to add another section 

 

 

 

 

  



Team Member 

Team Member shortcode allows you to list the team 

members with their profile. 

1. Upload the member picture 

2. Enter the member name and role 

3. Enter short description about the member 

4. Select URL to link to the member’s full profile 

page 

5. In Social Links tab, input the URL of member 

social accounts 

6. In Style tab, select a layout to display team 

members as well as set the color 

7. Save changes 

 

 

 

 

 

 

 

 

 

 

 

 

 



Testimonials 

Diacara makes it easy for you to display testimonials 

on your site page using Testimonials shortcode. 

 

To display testimonials, select a style to display the 

testimonials, then configure the display settings of 

the style including color elements. Each style has its 

own configuration. 

Testimonials Input 

1. Select Content tab 

2. Upload image to display as user who gives the 

testimonial 

3. Input the name, role, URL link, and the content of 

testimonials in the available fields 

4. Repeat the steps to input other testimonials as 

you need 

5. To adjust the font style, set it in Typography tab. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

  



Video Popup 

You can create a display image that will direct you to open a video in pop-up mode using Video 

Popup shortcode. 

General Settings 

1. Select a video popup style 

2. Input the URL of video to display 

3. Select color for icon and outline 

4. Select a type of icon alignment 

5. Check “Enable Text” to show text as the 

link 

Text Style 

2. Enter the text of the pop link 

3. Select a tag element for the title 

4. Adjust the title size in px 

5. Select a color for the title 

6. Input the content in WYSIWYG editor 

7. Set the content margin bottom in px 

8. Select content color 

9. Save changes 

 

 

 

 

 

 

 

 

 

 

 

  



Widgetised Sidebar 

If you want to add a widget area /sidebar in the page you are creating, use the Widgetised Sidebar 

shortcode. Simply input the title for the widget area and select a widget area you want to display. 

 

  



Theme Translation 

Base Theme Translation 

Included Language Files 

Diacara provides pre-created language files that you may check before starting your own translation. 

All these files have been contributed by our users so that the amount of translated strings might 

vary. 

Using Loco Translate plugin 

1. Go to Plugins > Add New > install and activate the Loco Translate plugin. 

2. Go to Loco Translate >Themes > select Diacara theme then press "Add new language". 

3. Translate strings and save your translation. 

 

 

https://wordpress.org/plugins/loco-translate/


 

Using PoEdit 

You can locate the translation file Diacara.pot within the Translation Files folder in the theme 

package. Edit the .po file using POEdit and use the translation field to make the replacements.   

From the file menu, save the file with the language name and Diacara theme prefix, e.g Diacara-

de_DE.po. It will generate both a .po and .mo files for your translation. After that place those files 

into the languages /wp-content/languages/themes/ folder. 

  



Backup & Restore 

WordPress database is very fragile, so you need to put an extra effort to keep your data safe. To 

prevent any data loss we’ve added an export/import feature for your theme option. To backup or 

restore your setting, please go to Appearance > Customize > Backup. 

NOTE:  

- Reset All button will erase all of your customization so that your theme will be like the first time 

you install it. 

- Please always backup your setting before you add/update plugins or theme to avoid data loss. 

Periodic backup is recommended. 

 

Export & Import Customizer 

Navigate to Appearance > Customize > Backup > Export Import then export / import the setting to 

backup your customizer setting. 

 

Header Backup 

Navigate to Appearance > Customize > Backup > Header Backup then export / import the setting to 

backup your saved header preset. 

 

Footer Backup 

Navigate to Appearance > Customize > Backup > Footer Backup then export / import the setting to 

backup your saved footer preset. 

 

 

  



Theme Update 

Updating Theme 

Updating a theme may not be a pleasant task, as you need to download the new version, backup the 

old version, delete files and reinstall the theme. Fortunately, Envato released Envato Toolkit a while 

back that makes everything automated and in just a few clicks away from keeping your website 

updated. 

NOTE: For preventing data loss, please backup your theme setting before updating theme/plugins, 

read how to backup in this section. 

 

Here is how to update your theme using Envato Toolkit plugin: 

1. Install and activate the Envato Toolkit plugin in your site (included in the theme package or 

download here). 

2. Get your Envato API Key. 

 You need to login to ThemeForest and visit your user profile page.  

 Click on Setting; you should see an API Keys tab in one of the section. 

 Click the Generate API Key button to get your API Key and copy it. 

3. Go to the Envato Toolkit menu on your dashboard, input your Envato username along with 

the API key then save your settings. 

4. Once you have your list of purchases displayed, you can install and update your themes right 

from your dashboard without having to login to ThemeForest. 

https://github.com/envato/envato-wordpress-toolkit/archive/master.zip


 

 

 

Updating Premium Plugins 

When you buy Diacara, you will get premium plugins such as WPBakery Page Builder & Revolution 

Slider for free. Please note that you will get the full-version of the plugin the same as when you 

purchased it as a standalone plugin. The only drawback is that you will not be able to receive support 

and automatic updates from the plugin’s author, rest-assured that we will always update the plugins 

in our theme’s updates. If you want automatic updates and support from the plugin’s author you 

need to purchase it separately (this is absolutely optional). 

Before you start updating, you need to get the latest files from ThemeForest. Choose the Installable 

WordPress file only option and extract the downloaded zip file and then save the folder in a safe 

place. 

To update the plugins manually: 

http://codecanyon.net/item/visual-composer-page-builder-for-wordpress/242431
http://codecanyon.net/item/slider-revolution-responsive-wordpress-plugin/2751380
http://codecanyon.net/item/slider-revolution-responsive-wordpress-plugin/2751380


WPBakery Page Builder 

1. Deactivate and delete the existing version of WPBakery Page Builder plugin within Plugins > 

Installed Plugins. 

2. Go to Plugins > Add New > Upload Plugin then click on Choose File button in the new page. 

3. Navigate to the extracted folder of the file you’ve downloaded before and select the visual 

composer file in Diacara\dahz-modules\plugins\js_composer.zip file. 

4. Start the installation by clicking on Install Now button. 

5. Activate the plugin and your WPBakery Page Builder is up to date. 

Revolution Slider 

The steps to update Revolution Slider plugin actually is the same as updating Visual Composer. The 

difference lies in what file to upload. For updating Revolution Slider, please upload Diacara\dahz-

modules\plugins\revslider.zip. 

 

NOTE: Removing the plugin to upload the updated one shouldn't delete your sliders, but you can 

export the sliders on your computer to have a backup copy. 

 

 

 

 

 

 

 

 

 

Denouement 

Once again, thank you for purchasing Diacara! 

If you still have a question that this documentation can’t resolve, please drop your inquiries in our 

support forum and we'll do our very best to assist you. We wish you all the best and we truly hope 

Diacara is really helpful for you in creating a professional website you’ve been dreaming of. Cheers! 

 

file:///D:/support.daffyhazan.com
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