
 

 

 

 

 

 

 

 

  



UPSCALE 

Multi-Purpose eCommerce WordPress Theme 

 

Thank you for purchasing Upscale!  

This documentation will guide you in building your dream site with Upscale. Please read carefully for any 

questions or issues you may be experiencing and to leverage theme’s capabilities. If your issue isn’t solved in 

this documentation, don’t hesitate to ask in our support forum. 

 

Follow us on ThemeForest, Twitter and like our Facebook for future projects and updates. 

We hope you enjoy building with our theme as much as we enjoyed developing it  

 

 

 

  

https://themeforest.net/user/dahz
https://twitter.com/Dahztheme
https://www.facebook.com/Dahztheme/


Installation 

Installing Upscale 

After purchasing from ThemeForest, you can download Upscale files from ThemeForest > Your Account > 

Downloads then select the installable WordPress file only to download. If you prefer to download the whole 

package, extract the package to get a single zip file titled upscale.zip (which is the WordPress theme file).  

 

NOTE: If you get “The package could not be installed. The theme is missing the style.css stylesheet.” error, 

please make sure you have downloaded the installable files from ThemeForest > Download option. 

TIP: Keep the downloaded file in a safe place as you are going to upload the file in the installation section 

Here are two options for installing Upscale:  

 WordPress: Navigate to Appearance > Themes > Add New.  

 

 

 

 



Click Upload Theme button then select the upscale.zip file.  

 

 

Press the Install Now button to start installing. 

 

 

 FTP: Using your FTP program, extract the upscale.zip file and upload the extracted folder to /wp-

content/themes/ folder on your server. 

After uploading, you need to activate the theme. Once WordPress has unpacked and installed the theme, just 

click activate or go to the Appearance > Themes then activate Upscale. 



 

 

 

Installing Required Plugins 

You will get additional plugins that bring more sophistication for Upscale’s functionality. You need to follow 

this few steps to get all the amazing features that they have. 

1. Go to the required plugins page from your dashboard within Appearance > Install Plugins or click from 

the notice that will appear after you installed the theme 

 

 



2. In the new page, simply check the box next to plugin to select all the plugins you want to install, then 

select the bulk action of install from the dropdown box and then click the apply button 

 

 

3. Wait for a minute or two until all the plugins are installed and click this link to go back to the Required 

Plugins page 

 



4. Now repeat the 2nd step but this time choose activate in the bulk action dropdown 

 

5. Finally WordPress will activate all the plugins and give you a notice that tells you everything’s done. 

 

NOTE: WooCommerce is included in the required plugins. 

  



Importing Demo Content 

Upscale quick demo installer is a tool to replicate the demo – including demo layout, customizer settings, 

posts, images and widgets to your site in a very simple process. 

 

1. Go to Appearance > Demo Install  
2. Make sure you meet all the requirements stated 

 Export Customizer Settings  

 Install the required plugins  

 Set your server memory limit to 256M and Max Execution Time (php time limit) to 900 

Seconds.  

 Set the WooCommerce image setting to: 

o Catalog Images: 600 x 764 px, hardcrop 

o Single Product Image: 1000 x 1273 px, hardcrop 

o Product Thumbnails: 180 x 230 px, hardcrop 

3. Choose the desired demo and click Install/Ok to start importing 
4. Done, your site has been upscaled! 



NOTE: This feature need you to install the edited version of WordPress Importer plugin.  If you already have 

the original WordPress Importer plugin installed in your site, please delete it first before installing our version.  

To install the edited version, from WordPress dashboard go to Appearance > Install Plugins after you install 

and activate the theme. If you want to upload it manually, please find the zip file in plugins folder of the theme 

package. 

 

Updating Theme 

Updating a theme may not be a pleasant task, as you need to download the new version, backup the old 

version, delete files and reinstall the theme. Fortunately, Envato released Envato Toolkit a while back that 

makes everything automated and in just a few clicks away from keeping your website updated.  

TIP: For preventing data loss, please backup your theme setting before updating theme/plugins, read how to 

backup in this section.  

Here is how to update your theme using Envato Toolkit plugin: 

 Install and activate the Envato Toolkit plugin in your site (included in the theme package or download 

here). 

 Get your Envato API Key. 

- You need to login to ThemeForest and visit your user profile page. 

- Click on Setting; you should see an API Keys tab in one of the section. 

- Click the Generate API Key button to get your API Key and copy it. 

 Go to the Envato Toolkit menu on your dashboard, input your Envato username along with the API key 

then save your settings. 

 

https://github.com/envato/envato-wordpress-toolkit/archive/master.zip


 Once you have your list of purchases displayed, you can install and update your themes right from 

your dashboard without having to login to ThemeForest. 

 

 

 

  



Updating Premium Plugins 

When you buy Upscale, you will get premium plugins such as Visual Composer & Revolution Slider for free. 

Please note that you will get the full-version of the plugin the same as when you purchased it as a standalone 

plugin. The only drawback you get is that you won’t be able to receive support and automatic updates from 

the plugin’s author, rest-assured that we will always update the plugins in our theme’s updates. If you want 

automatic updates and support from the plugin’s author you need to purchase it separately (this is 

absolutely optional). 

To update the plugins manually, you can follow this guide: 

Before you start updating, you need to get the latest files from ThemeForest. Choose the Installable WordPress 

file only option and extract the downloaded zip file and then save the folder in a safe place.  

Visual Composer 
1. Deactivate and delete the existing version of WPBakery Visual Composer plugin within Plugins > 

Installed Plugins. 

2. Go to Plugins > Add New > Upload Plugin then click on Choose File button in the new page. 

3. Navigate to the extracted folder of the file you’ve downloaded before and select the visual composer 

file in upscale\includes\plugins\js_composer.zip file  

4. Start the installation by clicking on Install Now button. 

5. Activate the plugin and your Visual Composer is up to date. 

Revolution Slider 
The steps to update Revolution Slider plugin actually is the same with updating Visual Composer. The 

difference lies on what file to upload. For updating Revolution Slider, please upload 

upscale\includes\plugins\revslider.zip. 

 

NOTE: Removing the plugin to upload the updated one shouldn't delete your sliders, but you can export the 

sliders on your computer to have a backup copy.  

 

  

http://codecanyon.net/item/visual-composer-page-builder-for-wordpress/242431
http://codecanyon.net/item/slider-revolution-responsive-wordpress-plugin/2751380
http://themeforest.net/downloads


Menu 

To create a new menu, go to Appearance > Menus, then click Create a new menu > fill your menu name > click 

Create Menu. Add to menu the item you want to add on the left hand boxes, then click Save Menu. Upscale 

has built-in mega menu where you can upload images to be the menu link. 

TIP: You can unlock more option to add to your menu (such as tags, categories, etc.) by clicking the screen 

option button at the top right corner of your screen and check boxes for the option there. 

 

Assign Menu Location 

Upscale features Six menu areas: 

1. Primary 

2. Top Bar 

3. Mobile Menu 

4. Footer 

5. WooCommerce Account 

6. Vertical Menu 

To assign location: 

 Navigate to Appearance > Customize > Menus, click the option titled Menu Locations. Select your 
menu location, by clicking the dropdown menu in each option then hit the Save & Publish button. 

Or 

 Go to Appearance > Menus > Menu Location tab > assign your menus to the location you want > Save 
Changes. 



 
 
NOTE: You can create submenus by dragging and dropping the items within other menu items. If you want to 

edit or remove a menu item, click the little arrow on the right-side of the menu item name. A selection of 

options will drop down, including editing the navigation label as well as removing the item altogether. 

 

Adding & Organizing Menu Items  

You can add pages, posts, links, and categories in the navigation menu by navigating to Appearance > Menus.   

 Page: Click the Pages dropdown heading. The pages you've created will be listed below. Check the box 
next to the page you'd like to add to your menu and click Add to menu.  

 Post: Click the Post dropdown heading. The post you've created will be listed under dropdown 
heading. Check the box next to the post you'd like to add to your menu and click Add to menu.  

 Link: Select the Custom Link dropdown menu. Enter your homepage’s URL into the field box and give it 
a title (such as ‘Home’) and click Add to Menu.  

 Category: Select the Categories dropdown menu, then you will see the category listed. Check the box 
next to your desired category and click Add to Menu.  

The selected item should now appear under ‘Menu Structure’ column. You can drag and drop the item you've 
added to adjust its location in the menu. You can also create submenus by dragging and dropping a menu item 
underneath another so that it's indented.  

Be sure to click Save Menu button after. 

 



 

NOTE: If you want to edit or remove a menu item, click the little arrow on the right-side of the menu item 
name. A selection of options will drop down, including editing the navigation label as well as removing the 
item altogether.  
 

Creating Mega Menu 

After setting up menu structure, you can set your menu as mega menu. Open up the setting of parent menu 

item, then check the Enable Mega Menu checkbox. You can also insert background images for displaying 

submenu items (optional). 



 

NOTE: For the guide in filling the Repeat 

Background Image, Background Position, and 

Background Size boxes, please read on w3schools. 

 

Configure Mega Menu Item 
Child menu or sub menu items in mega menu can be displayed as standard menu items, carousel, or custom 

images. If you want to display your menu items as a carousel or images, you need to do configurations in each 

menu item. 

Standard 

In the sub menu setting, select the options you want for the text align, number of column width, and number 

of submenu column to use.  

Carousel  

In the sub menu setting, check the Enable Carousel box. Select the options you want for the text align, number 

of column width, number of submenu column, and the carousel source. The carousel source you have chosen 

will generate the options on the carousel content so that you can choose which ones to assign easily. 

NOTE: For the best result of carousel megamenu, only use one sub menu.  

http://www.w3schools.com/cssref/pr_background-position.asp


Custom Image 

In the sub menu setting, select the options you want for the number of column width and the number of 

submenu column, then upload the image in Replace Link with Image option. 

 

Customize Menu Link & Dropdown Display 

Whether you set your menu display as regular menu or mega menu, you can customize the display of menu 

link and dropdown menu in the main navigation. 

To customize the display of menu link in main navigation, navigate to Appearance > Customize > Header > 

Header Main or Header Bottom. 

To customize the display of dropdown menu in main navigation, go to Appearance > Customize > Header > 

Dropdown Style, then set the display to your liking.  

 

 

 

  



Permalinks 

The URLs of each page and post you publish on WordPress are known as permalinks. By default, WordPress 

use plain (number) structure for the permalinks, but you can add or customize the structure to your liking 

within Settings > Permalinks on your WordPress dashboard. You can use the predefined structure or even 

create a custom one. 

We recommend choosing your permalink structure from the first day of installation so your readers and SEO 

crawlers can check and also be accustomed to your setting since the get go. 

NOTE: We use post name in Upscale demo 

 

 

  

http://en.wikipedia.org/wiki/Permalink


Header Area 

There are many possibilities you have to create your header in Upscale. You can easily use the drag and drop 

builder to create your website header. To begin modifying, navigate to Appearance > Customize > Header on 

your admin panel. There you can set up all elements in the header with the live preview on the right side. 

 

Header Builder 

 

When you go to the header settings, the drag and drop builder will appear on the bottom of the live preview. It 

allows you to drag and drop elements into header areas, which is divided into three rows. The rows in the 

builder represent each area in the header while the columns represent the position, depends on the layout 

you choose (e.g. in general, if you drop an element at the right side of the first row, the element will be 

displayed at the right side of your top bar). The placement order in a row also represents the position (stack) of 

elements. 

 First row: to drag and drop elements for the top bar. 

 Second row: to drag and drop elements for the main header area. 

 Third row: to drag and drop elements for the bottom of the header 

 Fourth row: additional row showing the pre-built elements that are not in use. You can drop elements 

you do not want to use here or drag elements to place it in the header. 

Clicking the blue gear symbol in each tab row or element will take you directly to the page settings of it. You 

can modify the selected area or element quickly without having to go to its section in header settings 

manually. 



 

Header Elements 

To view the list of header elements in use both in desktop and mobile version, you can go to the elements 

section in the header settings. 

 Menu and Top Bar Menu: show primary and top bar menu, which is set on menu settings (Appearance 

> Menus > Menu Locations) 

 Megamenu: show megamenu 

 Navigation Menu: mobile header menu setting; you can set it up from Appearance > Customize > 

Header > Header Sidebar/Mobile. 

 Logo: show your site logo; upload it from Appearance > Customize > Header > Logo & Site Identity. 

 Cart: show the cart icon to display your cart; to modify it go to cart section in header settings. 

 Wishlist: show the wishlist icon; go to Appearance > Customize > Header > Wishlist to modify. 

 Search: show the search bar; you can customize it from Appearance > Customize > Header > 

WooCommerce Search. 

There are two types of search element, which are search bar and search modal. For the search modal, 

it will show a pop-up where user can type their keyword then directly get the search result suggestion 

in columns, while the search bar shows the suggestion in dropdown mode. 

 Contact: show contact information which is set on the contact section of header settings. 

 Newsletter: show subscribe button to show sign-up form pop-up; set it within Appearance > 

Customize > Header > Newsletter. To set up the pop-up please read in this section. 

 Account: show account menu in the header; to modify navigate to account section in header settings. 

 Social Account: show list of social icons which style is set on social icon section in header settings. To 

set up your social account go to Appearance > Theme Option > Social Account. 

 HTML: any custom code to put in the header; you can input HTML code within Appearance > 

Customize > Header > HTML. 

 Button: button elements in the header; to modify, go to button section in header settings. 

NOTE: Cart, wishlist, and account element are available after installing and activating WooCommerce plugin 

and YITH WooCommerce Wishlist plugin. 

 

Header Customization 

Preset Header Layout 
In the preset section of header settings, you can choose the prebuilt layout to start creating your own header. 

You can safely preview each layout without losing changes. Click save to use the selected preset or go back to 

the header main settings if you do not want to use it. 

NOTE: It works best right after installing the theme or resetting options. 



   

 

Top Bar 
To customize the display of top bar area, navigate to Appearance > Customize > Header > Top Bar.  

If you do not want to use top bar on your website, drag and drop all elements in the first row of header builder 
into the fourth row (Not in Use row). 

 

 

Main & Bottom Header 
To customize the display of main header area, on your WordPress dashboard navigate to Appearance > 

Customize > Header > Main Header. There you can modify the color, size, and upload custom image for your 

main header background. 



To customize the bottom area, go to Appearance > Customize > Header > Bottom Header. Do not forget to 

click save & publish after making a change. 

      



Mobile Header 
To customize header’s appearance on mobile, please go to Appearance > Customize > Header > Header 

Sidebar/Mobile. 

          

Sticky Header 
You can customize the sticky header setting within Appearance > Customize > Header > Sticky Header. 

    

 



Header Transparency 
To customize header transparency, go to Appearance > Customize > Header > Header Transparent. In this 

section you can customize light and dark color schemes for the header elements. Before you custom the color, 

you need to go to a specific page which has the light/dark header transparent manually.

Choose a different header color scheme for a specific page  

You can set up specific page for the header transparency, 

simply by choosing a different option from the Header 

Transparency dropdown available in each page setting section 

or in Dahz Setting section when you create a new product, 

page, or post.  

For example, if you want to use light header transparency in 

portfolio page, navigate to Appearance > Customize > Portfolio 

> Portfolio Layout, then choose the light option from Header 

Transparency dropdown.

 

Custom HTML Code 
You can also add any HTML custom code to 

customize the header by navigating to 

Appearance > Customize > Header > HTML or 

Appearance > Customize > Header > Header 

Element Before After. 

 

 

Header Button 
There are two button styles to use in header. To customize the display of each button, go to Appearance > 

Customize > Header > Button. 

        

  



Insert Logo and Favicon 

Logo 

In Upscale, you need to upload 6 types of logo which are the default logo, logo for light & transparent header, 

logo for dark & transparent header, sticky logo, mobile logo, and footer logo. 

1. Navigate to Appearance > Customize > Header > Logo & Site Identity or Appearance > Customize > 
Footer > Footer Main 

2. If you haven’t built your header yet, select the logo position and header layout you want from the style 
section 

3. Upload your logo for all versions (default, transparent, sticky, mobile, footer, and retina) by clicking on 
select image button 

4. Browse your logo on the ‘Media Library’ or upload a new one, then click choose image 
5. Click save & publish to save your change or change file to choose another logo image.  

 
 
On the right side, you can see the live preview how your logo will be displayed.  
 
TIP: For retina logo, you need to upload another image with twice the size of your “normal” logo. You also 

need to make sure that the file have the SAME logo name and add @2x before file extension. For example, if 

your logo file name is “mylogo.png” (resolution 200 x 20px), you should upload another named 

“mylogo@2x.png” (resolution 400 x 40px) for the retina logo.  

NOTE: Upscale’s default logo in the demo is set at 141 × 60px. 

 

 

 

 



Favicon 

1. Navigate to Appearance > Customize > Header > Logo & 
Site Identity  

2. Scroll down to the Site Icon Logo section  
3. Click on select image button to upload your favicon logo 
4. Browse your favicon on the ‘Media Library’ or upload a 

new one, then click choose Image 
5. Click save & publish to save your change or change file to 

choose another logo image. 

NOTE: Icons must be square, and the minimum resolution 
is 512 pixels wide and tall. 

 

 

 

Site Title & Tagline 

You can also set up your site title and tagline from the Appearance 
> Customize > Header > Logo & Site Identity section. Enter the site 
title and tagline in the available fields. If you also want to display 
the tagline under the logo, check the ‘show tagline under logo’ 
box. 

 

  



Homepage 

 

Homepage is the first page visitors will see when they arrive at your website. By default, the homepage will be 
the page displaying all of your posts, beginning with the most recent where you can change the layout within 
blog layout.  

Choosing Page for Homepage and Blog Page 
By default, your homepage will display your post feed, listing all of your latest posts for visitors to see. You can 
make your homepage as a static page and display your post feed on a separate page. 



 Create your new homepage and blog pages within WordPress Dashboard > Pages > Add New or you 
can choose your page that is already created.  

 Navigate to Settings > Reading or Appearance > Customize > Static Front Page. You will see a section 
titled ‘Front page displays’ then choose ‘a static page’ option. From the Front page dropdown menu, 
select the desired page to be your homepage and from the Posts page dropdown menu select the 
desired page to be your blog page. Be sure to save changes when finished. 

 

 Navigate to Appearance > Menus to add homepage and blog page to navigation menu. Click the pages 
dropdown menu on the left, check the boxes next to your home and blog pages, and then add them to 
the menu. Drag and drop them to wherever you’d like them to be positioned in your menu. Be sure to 
save when finished. 

 

  



Sidebar & Widgets 

 

Sidebar 

A sidebar is a content area usually displayed on the left or right area of the page. Customize your sidebar by 

stacking up different widgets that display a variety of things and choose where you want to display it.   

1. Sidebar : Main sidebar that appears on the page that enables sidebar 

2. Shop : Sidebar that only appears on shop page or single product, you can use this sidebar to display 

custom filter for your products. 

3. Footer : Footer sidebars that appears on the bottom of your site. 

To enable or disable sidebar on each page, you can change the sidebar layout from each page setting (such as 

blog page setting in Appearance > Customize > Blog > Blog Layout) or specifically on a product, post, or page by 

changing the sidebar layout option in the Dahz Setting when you create one. 



 

 

 

To enable or disable sticky sidebar, navigate to Appearance > Customize > General > Global.  

NOTE: In Upscale we also add extra sidebar as the option to display navigation menu in desktop and mobile 

named Header Sidebar. To enable it, navigate to Appearance > Customize > Header > Header Sidebar/Mobile. 

 

 

 

 

 

 

 

 

 

 

 



Widgets 

To set your widget, go to Appearance > Widgets. You can drag & drop widgets you want from the available list 

on the left side into the available area on the right side. Another way to add the widget is navigating to 

Appearance > Customize > Widgets. 

 

Upscale has 7 different custom widgets to choose. 

 DF Commerce Widget Brands: to display brand logo or text. 

 DF Commerce Widget product by SKU/ID: to display product by certain SKU or ID (for example 

showing New Arrival product).  

 DF Commerce Widget Woocommerce Categories: to display product categories with image banner. 

The image is assigned within product categories setting. 

 DF Widget Categories: to display post categories with image banner. The image is assigned within post 

categories setting. 

 DF Widget About Me:  to display your profile where you can add an image, description and social 

network of yours. 

 DF Widget Author: to display other authors’ info 

 DF Widget Banner: to display banner 

To create a banner, enter banner info (title, text, and image alt text), input the image URL in Image 

box, directed link in Image Link box, and banner height number in px (only input the number, e.g. 300). 

Click save to finish. 

 

NOTE: To get the slug category, head to Products > Categories (for DF Commerce widgets) or Posts > 

Categories (for DF widgets), quick edit the category you want to input, then copy the slug.  



Footer Area 

 

The same as building your header, you can easily use the drag and drop builder to create the website footer. 

Navigate to Appearance > Customize > Footer on your admin panel to set up your footer.  

 

Footer Builder 

 

In the footer settings, the drag and drop builder will appear on the top of the live preview. It allows you to drag 

and drop elements into footer area, which is divided into two rows. The rows in the builder represent each 

area in the footer while the columns represent the position depends on the layout you choose (e.g. in general 



if you drop an element at the right side of the first row, the element will be displayed at the top right side). The 

placement order in a row also represents the position (stack) of elements. 

 First row: to drag and drop elements on the top of footer area, may consist of every footer element. 

 Second row: to drag and drop elements on the bottom of footer area; can only consists of payment 

logos, copyright text, footer menu, and footer social icon.   

 Third row: additional row showing the pre-built elements that are not in use. You can drop elements 

you do not want to use here or drag elements to place it in the footer. 

NOTE: The number of column depends on the chosen footer layout. Every time you change the footer layout, 

you need to re-assign the elements into the builder. 

The builder provides the shortcut to modify each element using Edit button for each element. The button will 

take you directly to the page settings of the element without having to go to its section in footer or widget 

settings manually. 

 

The elements you can input in footer area are logos, description, social icon, widgets, and copyright text.  

 Footer Logo: add your site logo; upload it from Appearance > Customize > Footer > Footer Main. 

 Footer Description: add your website short description in the footer; the Footer Description text box is 

in Appearance > Customize > Footer > Footer Main.   

 Footer Menu: add navigation menu, which is set on menu settings (Appearance > Menus > Menu 

Locations) 

 Footer Social Icon: add a list of social icons; navigate to Appearance > Theme Option > Social Account 

to set up the social accounts. 

 Payment Gateway Logos: add the payment gateway logo images; modify it by going to Subfooter 

section in footer settings. 

 Copyright Text: add a copyright or disclaimer text; to edit the text navigate to Appearance > Theme 

Option > Footer > Subfooter, then change the text on ‘Copyright Text’ box.  

 Footer Widget: add a widget to the footer area; modify it from Appearance > Customize > Widgets. 

 

Preset Footer Layout 

In the preset section of footer settings, you can choose the prebuilt layout to start creating your footer. You 

can safely preview each layout without losing changes. Click save to use the selected preset or go back to the 

main footer settings if you do not want to use it. 

NOTE: It works best right after installing the theme or resetting options. 



 

 

Footer & Subfooter Customization 

To customize the display of footer area, on your WordPress dashboard navigate to Appearance > Customize > 

Footer > Footer Main or Appearance > Customize > Footer > Subfooter for subfooter area. There you can 

modify the layout, color, size, and upload custom image for your main header background. 

Do not forget to click save & publish after making a change. 

 



         

Custom HTML Code 

You can also add any HTML custom code to customize the footer within Appearance > Customize > Footer > 

Before & After Footer. 

    



Visual Composer 

Upscale uses Visual Composer to help you customizing your pages or creating complex layouts within minutes. 

You can change the WYSIWYG editor (WordPress default editor) into Visual Composer editor for creating posts 

or pages. You can add many elements and row in your post or page with Visual Composer. 

 

For more detail documentation of Visual Composer, please check Visual Composer Official Guide and Visual 
Composer Video Tutorials. 
 

Adding Row and Elements 

 Click the Backend Editor button at the top of WYSIWYG editor, then the editor will be changed to 
Visual Composer canvas. 

 

 Click on the Add Element button or the + sign at the top of the editor box. 

 Choose an element from Visual Composer elements list. 

http://go.wpbakery.com/getting-started
https://vc.wpbakery.com/video-tutorials/
https://vc.wpbakery.com/video-tutorials/


You can add other elements in the same row or add one in a new row first.  

 To add element in a new row, click on a big + sign in the middle of that new row.  

 

 To add the element in the same row, click the plus button that says ‘add column’ or ‘prepend to this 

column’.  

 

Drag and drop the rows to arrange the position of your content. 

 

 

 

 

 

 

 

 

 



Enable Visual Composer in Custom Post Types 

If you don’t see the Backend Editor button, navigate to Visual Composer > Role Manager. From the 

Administrator tab section select ‘Custom’ on Post Types dropdown, then check the box of the post types on 

which you want to use the Visual Composer.  

 

Shortcode Guide 

We provide our custom elements (shortcodes) in addition to Visual Composer elements. The shortcodes are 

available through the Visual Composer interface, simply by selecting the by Dahz Commerce tab, then you can 

see the list of our custom shortcodes you can add to post or page content. 

 

NOTE: 

- Some shortcodes require you to set up the padding manually, to learn more about padding, please read 

about CSS Padding. 

- Some shortcodes let you use custom icon by uploading it or input the icon class from Font Awesome and 

Outicons. 

- When you upload an image, please wait until you can see the thumbnail of the uploaded image, otherwise 

the image won’t show properly. 

 

http://www.w3schools.com/css/css_padding.asp
http://fontawesome.io/icons/


Create Product Tagging On a 
Photo 

Use DF WooCommerce Quickview shortcode to create product 

tagging on a photo. When you click the tag, the product 

quickview will pop up on your screen.  

1. Upload the image that contains the product you want to tag  

2. Click on the wherever area on the photo to assign the tag 

and choose the tag color, then click save  

3. Choose the tag style 

- Style 1: Only show the tag button 

- Style 2: Show the short product information when you 

hover on the tag button 

- Style 3: List the product information and link instead of 

showing the tag button 

4. Save changes 

 

 

 

 

 

 

 

 



 

Customize Add To Cart Button 

Add To Cart Custom shortcode allows you to show the price and add to 

cart button of a product. Simply choose the product ID from dropdown 

option and set the appearance to your liking. 

 

 

 

Create Banner 

 



Banner shortcode allows you to create a banner, both image and video banner. You can read the w3school 

guide to help you in creating the banner height and padding 

1. Input the height for banner, for example 500px. 

2. Select an image for the background, or you can select a color for the background. 

3. Select the color for overlay. 

4. Set up the border width, color, and style.  

 

5. If you want to create video banner, put the link from Youtube or HTML5 video URL. If you assign the image 

before, then it will keep displayed as the background image. 

NOTE: We recommend you to input HTML 5 video so that you can adjust the size of video with the banner. 

6. Set up the banner inner width, padding, position, text alignment, and background color. It will determine 

how your content will be displayed in the banner. 

7. Set up the width, radius, and color for border banner inner. 

8. Input your content in the text banner/WYSIWYG editor. If you set up the different alignment from the 

banner inner setting before, then the setting in text banner will be overwritten with the banner inner 

setting. 

9. Input the button title and select the color element for the button. 

10. Select the style for the button. If you want you can input an icon beside the button title. 

11. Input the link for the button. You can create another button by checking the Enable Secondary Button box. 

12. Save changes. 

 

http://www.w3schools.com/css/css_padding.asp
http://www.w3schools.com/css/css_padding.asp


 

 



 

 



 

 

 

 

  



Create Button 

 

You can create a button using Button shortcode. Simply add the button text, link, and style. 

 
 

Display Location Maps 

 

You can show location map using Google Maps shortcode. To use this shortcode, please generate your Google 

Map API Key first, then set up the map setting for your location by entering the latitude and longitude of your 

location. You can also upload your custom marker icon within the Marker tab section. 



 

 
 

 

Display Social Icons 

Use Social Media shortcode to display social icons linked to your 

account. You can set how all of your social accounts will be 

displayed. If you need to set up your accounts, read this section. 

 

 



Display Vertical Menu 

 

Vertical Menu shortcode allows you to show menus you have assigned to vertical menu. If you have yet to 

assign a menu to vertical menu, navigate to Manage Locations tab within Appearance > Menus. 

NOTE: You shouldn’t choose the full column width to assign the vertical menu. For example you can choose to 

use the two columns (1/2+1/2 width).  

 



 

  



Create Carousel Container 

 

You can create a carousel that consists of other shortcodes by using the Carousel Container shortcode. 

1. Set the number of column for each device 

 

2. Click the + button inside the carousel container column 

 



3. Click the Carousel Item shortcode 

4. Click the + button inside the carousel item column 

 

5. Add element for the carousel 

6. To add another carousel item, click the + button outside the carousel item box (it says ‘append to this 

carousel container’ 

 

 

 

Create Countdown 

 

Create countdown timer on your site easily using the Countdown shortcode. Simply set up the type of 

countdown to use, colors for background and element, then fill the countdown year, month, date, and hour (in 

24 hour format). Check the week, day, hour, minutes, and/or second boxes to display the element. 



 

 

 

  



Filter Latest 

Filter Latest shortcode is used to display the filter options to sort your search to only display the latest 

products, posts, Instagram photos or all of them. To use this shortcode you need to set up your Instagram 

OAuth first. 

1. Input how many product, Instagram post, and post to show 

2. Input the number of content and column to display in a page 

3. Input the number of image loading after the first page (load more) in the Item Added field 

4. Fill the Instagram hashtag if you only want to display photos with specific hashtag 

5. Set the based order, sort order, and pagination style. For order by name, it will be generated from the 

caption of the image post. 

6. Save changes 



 

 

 

 

  



Show Image as Banner or Gallery Lightbox Link 

 

 

You can display an image that will show a gallery lightbox or redirect to another link address when clicked. 

Select the Image Filter shortcode then simply upload image(s) to display and select lightbox or link to use. 

Custom the element to your liking. 



 

 

Create Images into Video Loop Banner 

     



You can create a banner consisted of few images that will be displayed like a GIF image with Image Rotator 

shortcode. To create one, add and custom the text to display over the banner in the WYSIWYG editor (or you 

can leave it blank), set the interval for changing image, then add all images you want for creating the loop. 

 

 

NOTE: If you check the Manual box for Select Images, it means that the loop can only be seen when you hover 

on the image. 



Showcase Instagram Feed 

Instagram Custom Feed shortcode allows you to create Instagram feed which displays your Instagram photos. 

It displays all photos from your Instagram account or only some of them that have the same hash tag. 

Authenticate Instagram oAuth first before you use this shortcode. Simply set up how many Instagram post to 

show, the number of column, the order, and caption position. If you only want to show posts with specific 

hashtag, input the hashtag in the Tags field. 

NOTE: If choose the order by name, then the order will be generated from the caption of the photos. 



 

 

  



Create Message Box 

 

 

You can create a box where you can input your message text and a button using Message Box shortcode. Input 

the message box height, message content in the WYSIWYG editor, button title, and button URL. You can also 

make the message like a banner image by adding the message background image.  

 

 



 

 

Display Products with New Badge 

 



New Products shortcode lets you display products that have new badge assigned. Simply set how many 

product to show, how many column for the products, and the based-order to show. To assign the badge, go to 

the Dahz Setting custom metabox when you add or edit a product. 

 

 

Create Button to Show Newsletter Popup 

 



Newsletter Popup shortcode creates a button that will display the pop-up of newsletter sign-up form. You need 

to set up the newsletter pop-up display, so that you can have 2 different type of newsletter pop and the pop-

up you create using this shortcode will only appear if you click the button. 

1. Select the style of button which can be a text or custom image. If you select the text style, you add icon 

which will appear beside the text. 

 

 
 

2. Insert the image, title, and content for the newsletter pop-up 

 

 
 

 

 

 



3. Input the form shortcode 

 

 
 

4. Save changes 

For more detail about setting up newsletter, read this section. 

TIP: If the button on the pop-up is not displayed properly, add class="de-btn de-btn--boxed de-btn--

fill" or class="de-btn de-btn--boxed de-btn--outline" to the MailChimp form setting.

 

 

  



Display Post Carousel 

 

You can create a carousel of display images linked to other posts on your site with Post Carousel shortcode. 

You can choose the posts to display based on the category, post ID, or recent posts. 

 
 

  



Display Product Categories or Brand 

 

You can display product categories or brands using Product Categories or Brand – Grid shortcode. The images 

of product categories or brands will be displayed in grid layout. You can display all categories/brands, only the 

parent categories/brands, or some categories/brands specified by IDs. To assign the category or brand images, 

head to Products > Brand or Products > Categories then upload the brand or category header.  

 

 
 

 



NOTE:  

- If you have categories with child categories, by default this shortcode will show all of it (both parent and 

child categories). To hide the child categories, input 0 (zero) on the parent field. 

- For category/brand IDs, hover on the title then see the link on the bottom. The number after ‘ID=’ is the 

number you need to input. 

 

 

Display Product by Brand 

 

Product by Brand shortcode allows you show products from the same brand. Simply choose the brand, the set 

up how to display them. 



 

 

Display Product Carousel 

 

You can create a carousel of your products using Product Carousel shortcode. You can choose the product to 

display based on the attributes of the products such as category, SKU number, top rated, etc. 



 
 

Showcase Product 

 



You can show all products you choose using Product Showcase shortcode. It will be displayed as a single 

product information like you see in the single product or quickview in fullwidth mode.  To assign the product, 

simply type the name of the product. 

 

 

  



Show Recent Products 

 

Recent Products – Masonry shortcode lets you display the latest products added to the store in a masonry 

layout. Simply set up the setting to display the products such as number of products to display per page and 

the number of column to use. 



 
 

 

Create Scroll To Element 

 



Scroll To shortcode creates a scroll button that direct user to another section in the post or page.  

1. Before you add this shortcode, set up the row ID of the target section first by clicking the Edit This Row 

button 

 

2. Input the row ID, then save changes 

 

3. Next, add a new row then assign the Scroll To element. 

4. Input the target row ID and select the color you want for the bullet 



 
5. Save changes. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



If you choose to hide bullets, then you need to assign a button as the scroll to element. Assign a button, then 

input the link as #Row ID, for example #productbrand 

 

 

 



Show Team Member 

 

Team Member shortcode allows you to list the team members with their profile. Simply add the image, social 

account, and description of the member. Don’t forget to assign the same size of images and change the 

column width as you need. If you don’t want to assign social accounts, please leave it blank. 

 

 
 

Create Video Banner 



 

With Video Banner shortcode you can create an image banner that will turn into a playing video when you 

hover on it. Simply upload the image, add the title, title URL, caption and video URL. You can custom the color 

for the title and caption. 

 



 

 

Create Pop-Up Video with Image Banner  

 



 

You can create a display image that will direct you to open a video in pop-up mode.  

1. Add the background image for image banner 

2. If you enable text, add title and caption, then custom the color element 

3. Input the video URL for the pop-up 

4. Select the style for the button; if you choose image, you can upload icon on your own, but if you choose 

icon, then you need to input icon class from Font Awesome or Outicons. 

5. Check the Hover Text box if you only want to display the title and caption when you hover on the banner 

6. Save changes 



 

 

 

 



Split Slider 

 

Split Slider shortcode allows you to display two contents at the same time by splitting the screen area for each 

content as left and right content. You can insert other shortcodes in creating the content like you can do when 

using Carousel Container shortcode. 

1. Add Split Slider shortcode, , then set the color for the dots of slider  

2. Click the + button inside the Split Slider column 

 

3. Select the side you want to assign the content, e.g. Split Slider Left 

 

4. Click the + button inside the Split Slider Left column 

 

5. Click the Split Slider Item option 

6. Set the background color, padding, and content alignment; if needed you can also upload a background 

image, then click Save Changes 



 

7. Click the + button inside the split slider item column 

 

8. Add element you want for the split slider content. If you want to add another content, select the + button 

to add split slider item 

 



9. Repeat the same step for the other side (Split Slider Right) 

NOTE: If you want to use split slider, the header setting should be set as transparent header and don’t add 

other content after it. If you don’t want to show the header, simply select page blank template. 

 

  



Revolution Slider 

Upscale includes Revolution Slider plugin to add a slider on page.  

For more detail documentation, please check Revolution Slider Official Guide and Revolution Slider 5.x Video 

Tutorials. 

Import & Export Slider 

Import 
Overwrite current slider settings and slides with those from the imported slider zip. 

 Browse: select the slider import zip from your computer. 

 Custom Animations / Static Styles 

o Overwrite: overwrite previous styles and animations with those from the imported slider. 

o Append: preserve previous styles and custom animations (usually the best option). 

 

1. Go the the Revolution Slider tab in your WordPress Admin Panel, and click the Import Slider button. 

2. Choose the zip file of the slider you’d like to import. 

3. Once you’ve chosen the zip file, an Import Slider button will appear. 

4. Click the Import Slider button, and wait for it to finish uploading. 

5. Once it’s finished uploading, you will see your imported slider in the list of Revolution Sliders available. 

Export 
Export the current slider, creates a “zip” file that can be saved to your computer for later usage (i.e. 

“imported” to a different website). 

 

Add Slider on Page 

From Visual Composer Editor 
 Click on the Add New Element button or + sign 

 Select the Revolution Slider 5 element 

From WYSIWYG Editor 
 Select the Revolution Slider icon 

 Select a slider you want to use then click on Add Selected Slider button. 

  

https://www.themepunch.com/revslider-doc/slider-revolution-documentation/
https://www.youtube.com/playlist?list=PLSCdqDWVMJPPDcH_57CNZvLckoB8cimJF
https://www.youtube.com/playlist?list=PLSCdqDWVMJPPDcH_57CNZvLckoB8cimJF


Contact Info 

In Upscale you can display your contact information in the header area and create a contact page.  

To set up the information in the header, go to Appearance > Customize > Header > Contact. For the location 

map, you need to generate a link to your location from Google Map.  

Share a link to your location 

1. Type your location address in the search bar. 

 

 

2. After locating your address, click on the Share button. 

 



 

3. Copy the share link then paste it in the Location Map box. 

 

 

Contact Page 

NOTE: Be sure that you have installed and activated the Contact Form 7 plugin.  

Creating the form  
 Navigate to WordPress Dashboard > Contact > Add New then simply click Add New button. 
 Make sure the form elements & email information look correct, then click Save button.  

Creating the page  
 Create a new ‘Contact Us’ page and add it to your navigation menu if you have not already done so.  
 Copy and paste the generated contact form shortcode (see the screenshot below) into the text box on 

the create/edit page screen. And contact form will appear when the page is published.  

 
 
 

  



Enable/Disable Comment 

To enable/disable the ability for your visitors to post comments on your page, you can go to Appearance > 

Customize > General > Global, then locate the comment option. 

 

Back to Top Button 

If you enable the Back to Top button within Appearance > Customize > General > Global, an arrow up button 

will be displayed when you scroll down the page. It will redirect visitors to the top of the page. 

Customizing 404 Page 

You can custom the title and subtitle for 404 page by navigating to Appearance > Customize > General > 404 

Page. If you choose to show the latest product section on the 404 page, you can also set up the number of 

column and total product to display. 

     

Enable/Disable Lazy Load 

To enable/disable lazy load feature on your site, navigate to Appearance > Customize > General > Global. 

 

  



Custom Metabox for Posts or Pages 

Besides selecting layout generally for posts or pages, you can manage the appearance of a specific post or page 
when creating one. Upscale includes custom metabox in each post or page editor that allows you to modify the 
layout of the current page or post you create. You can disable sidebar, disable footer, add an affiliate widget, 
add custom HTML code, and many more.  You can find our Dahz Setting custom metabox when creating a 
post, page, portfolio, or single product right under the WYSIWYG content editor. 

The customization you have made in Dahz Setting will only affect the selected post or page. In general, the 
layout settings automatically follow the default setting you have set in live customizer (within Appearance > 
Customize). 

General Layout 

In all Dahz Setting, you can find General Layout tab section which allows you to modify the layout elements 

such as header and sidebar or add elements to your post or page such as adding a product video. Options in 

General Layout section are varied for each page or post. For example, in Portfolio you can only see the options 

for header and color elements, while in Pages you can select the sidebar and page title layout along with the 

options to disable footer and breadcrumbs. The image below is the General Layout section in creating a page. 

  

 

 

 

 

 



Element 

You can find Element tab section in the Dahz Setting of page, portfolio, and product. In Element section you 

can add custom HTML code to modify the layout. 

 

Subtitle 

Subtitle tab section can only be found in the Dahz Setting when you’re creating or editing a post. It allows you 

to add a subtitle for the title of your post. 

 

 



Affiliate 

Same as Subtitle, Affiliate tab section is only available in the Dahz Setting when creating a new post. It allows 

you to embed an affiliate widget to your post. After assigned, the widget will be displayed at the bottom of the 

post page. 

 

Portfolio 

Portfolio tab section is accessible when you’re creating or editing a portfolio.  In this section you can add a 

short description and modify the header title by adding a video and/or image header. 

 

  



WooCommerce 

To fully enjoy eCommerce features in Upscale, you have to install and activate WooCommerce plugin. If you 

have installed and activated the required plugins after installing the theme, WooCommerce plugin is already 

activated on your site. If you skip the step, navigate to Appearance > Install Plugin, select WooCommerce 

plugin from the list, then install and activate it. 

For more detail documentation, please check WooCommerce Official Guide and WooCommerce Video 

Tutorials. 

Adding WooCommerce Pages 

After activating WooCommerce plugin, you will see a notification to install WooCommerce pages at the top of 

the page. Click the Install WooCommerce Pages button so that all WooCommerce pages will be created on 

your site. The pages are also assigned to each page setting automatically. 

WooCommerce Settings 

To set up WooCommerce, go to WooCommerce > Settings on your admin panel. 

 

Product Image Size  
As WordPress has a limited image resizing and cropping system, we need to optimize the display of product 

image.  

1. Select Products tab from the WooCommerce settings 

2. Select Display sub tab 

3. Change the setting in the Product Image section. 

https://docs.woocommerce.com/
https://woocommerce.com/videos/
https://woocommerce.com/videos/


 

We recommend you to follow the same settings as in our demos, but feel free to change the setting as you 

desire. 

 Catalog Images: 600 x 764 px, hardcrop 

 Single Product Image: 1000 x 1213 px, hardcrop 

 Product Thumbnails: 180 x 230 px, hardcrop 

NOTE: If you change these settings after uploading product images, you need to regenerate the images to 
apply the changes. We recommend you to use the Regenerate Thumbnails plugin. After activating the plugin, 
navigate to Tools > Regen. Thumbnails > Click Regenerate All Thumbnails button. Refresh your gallery to see 
the change. 

 

WooCommerce Pages 
NOTE: WooCommerce automatically assign the pages when you install the pages by clicking the button in the 

notification. 

Assign Shop Page  

1. Select the Products tab from the WooCommerce settings. 

2. Select the Display sub tab. 

3. Choose the page to assign from the Shop Page dropdown options. 

Assign My Account Page  

Select the Accounts tab from the WooCommerce setting, then choose the page to assign from the My Account 

Page dropdown options. 

Assign Cart and Checkout Pages  

Select the Checkout tab from the WooCommerce setting, then choose the page to assign from the Cart Page 

and Checkout Page dropdown options. 

 

Currency 
To set the currency on your website, go to select the General tab in WooCommerce settings. Configure your 

currency in the Currency Options section. 

http://wordpress.org/plugins/regenerate-thumbnails/


 

 

For more details of WooCommerce settings, you can watch the tutorial videos: 

 General Store Settings 

 Products Settings 

 Tax Settings 

 Tax Rate Example 

 Checkout Settings 

 Accounts Settings 

 Email Settings 

 

  

https://woocommerce.com/videos/woocommerce-general-settings/
https://woocommerce.com/videos/products-settings/
https://woocommerce.com/videos/tax-settings/
https://woocommerce.com/videos/tax-rate-example/
https://woocommerce.com/videos/checkout-settings/
https://woocommerce.com/videos/accounts-settings/
https://woocommerce.com/videos/emails-settings/


Adding Products 

To add a product, navigate to Products > Add New from your WordPress dashboard. You can watch these 

videos to learn how to add each type of product: 

 Simple Product 

 Grouped Product 

 Variable Products 

 External/Affiliate Product 

 Downloadable Product 

 

Add Product Images 
As Upscale has many variations of the shop page layout and single product layout, you need to assign the 

proper images for each layout. Upload product images and product gallery for portrait and/or landscape 

mode, depending on the layout you use. 

Upload the portrait images in the product image and product gallery section, while the landscape images are 

uploaded within Dahz Settings that you can see on the right sidebar. 

                    

https://woocommerce.com/videos/woocommerce-simple-product-overview/
https://woocommerce.com/videos/woocommerce-simple-product-overview/
https://woocommerce.com/videos/woocommerce-grouped-product-overview/
https://woocommerce.com/videos/woocommerce-grouped-product-overview/
https://woocommerce.com/videos/woocommerce-variable-product-overview/
https://woocommerce.com/videos/woocommerce-external-affiliate-product-overview/
https://woocommerce.com/videos/woocommerce-downloadable-product-overview/


 

 

Product Categories, Tags, and Attributes 
Watch the tutorial here. 

NOTE: In Upscale, you need to choose page layout for each product category or simply choose one layout for 

all product categories in the customizer.

For attributes, Upscale has developed a way to let 

you add attribute terms that will display colors and 

images of product. After creating an attributes, 

create the terms that you can be assigned to label 

(text), color or image for each. Color and image 

terms later can be created as product swatches. 

TIP: Create the terms in the same type first (e.g. 

creating terms with color type) so they will be 

displayed in the widget tidily. 

 

NOTE: If you choose to use image type, upload an 

image with 1:1 aspect ratio. 

 

 

 

https://woocommerce.com/videos/product-categories-tags-shipping-classes-attributes/


Create Color and Image Swatches 
In Upscale you can add color and image swatches that will display the product variable attributes. When you 

create or edit a product, assign the product attributes first that you have created (within Products > Attributes) 

to create the swatches. 

1. In Product Data section, choose variable product from the dropdown option. 

 

2. Go to Attributes tab section, then choose the attributes you want to use. 

3. Type the attribute terms in the Value(s) field or simply click select all button to generate all terms, 

check the Used for variations box, then click Save attributes. 

 

4. Next, go to Variations tab section. From the dropdown menu select add variation or create variations 

from all attributes to generate all terms of attributes you have chosen in Attribute tab. 

5. Expand the attribute term setting, then assign product images of the selected attribute by clicking the 

Upload Additional Image button. The first and second image uploaded will be the primary images 

based on the layout you use (if it displays one or two primary images), then the rest will appear as the 

gallery. 

6. Now let set the thumbnail to display the attribute terms. Go to DF Swatches tab section, then select 

the thumbnail type you want. 

 None: default WooCommerce setting (dropdown) 

 Taxonomy: global setting (all type of terms you have created in Products > Attributes)  

 Custom color or image: color or image  

7. Add additional product images for each attributes that will be used on the shop page by expanding the 

attributes setting. Upload the portrait and/or landscape product images. 



 Preview Shop Archive on Click: The product images that will appear when user clicking the 

swatches. 

 Preview Shop Archive on Hover: The product images that will appear when user hover on the 

photo after selecting the swatch. 

 

NOTE: To show the swatches in shop page, you should enable it within Appearance > Customize > 

WooCommerce > Shop.  



Add Product Badge 

 

You need to enable the product badge first before you can add a badge to a product. Read this section to 

enable product badge. 

 To assign ‘new’ badge to a product, scroll down to Dahz Setting when you create or edit a product, 

then check the Display Badge box in General Layout tab section.  

If you set custom text badge as the ‘new’ badge, you can change the text you have set before in the 

product badge setting. Simply type the text in the Rename Badge box. 

NOTE: The custom text you enter on the Rename Badge box will only apply to the selected product, it won’t 

affect other products with the ‘new’ badge as they will display the custom text you have set globally in the 

product badge setting. 



 

 To assign ‘sale’ badge, scroll to the Product Data, select the General tab, then enter the sale price for 

the product. It will generate ‘sale’ badge for the product automatically. 

 

 

Order, Shipping, and Coupons 

 To learn more about order management, watch these videos: 

o Managing Orders 

o Refunds 

o Reporting 

 To learn more about coupons, watch the video here. 

 To learn about shipping settings, you can watch these videos: 

o Shipping Zones 

o Shipping Options  

o Shipping Classes 

https://woocommerce.com/videos/woocommerce-managing-orders/
https://woocommerce.com/videos/woocommerce-refunding-orders/
https://woocommerce.com/videos/woocommerce-reporting/
https://woocommerce.com/videos/woocommerce-widgets/
https://woocommerce.com/videos/shipping-zones/
https://woocommerce.com/videos/shipping-zones/
https://woocommerce.com/videos/shipping-options/
https://woocommerce.com/videos/shipping-classes/


WooCommerce Widgets 

WooCommerce widgets are mostly used for product filters. To learn more about the WooCommerce widgets, 

please watch the video here. 

NOTE: WooCommerce widgets can only be assigned to shop sidebar area. 

 

 

 

 

  

https://woocommerce.com/videos/woocommerce-widgets/


Customizing Shop 

Shop Page 

Configure the appearance of shop page and its elements within Appearance > Customize > WooCommerce > 

Shop. 

Shop Page Layout 
Upscale features 6 different layouts for the shop page. You can choose the layout you prefer to showcase your 

products in the Layout section. 

 

In this section you can also customize the number of column to display for each device, how many product to 

display per page, show/hide product star rating, and product info to display.      

Shop Page Pagination 
Upscale has 4 styles of pagination for the shop page: number pagination, number-ajax pagination, infinite load 

with button, and infinite load scroll. 

Hover Animation Setting 
You can choose the animation to use when you 

hover on the product photos. There are 4 options 

of image hover animation to select. 



Page Title Layout 
You can display the title of your shop page in 4 variations in each shop page section. 

 Shop Homepage Title: Choose the page title variation for shop homepage 

 Category Page Title: Choose the page title variation for shop page based on category (e.g. Tops) 

 Brand Page Title: Choose the page title variation for shop page based on product brand

  

Display Elements 
Product Attributes  

You can show or hide product attributes from the Attributes Swatches section. Product attributes you can 

show are color and size.

Product Badge  

For product badge, scroll down to the Badge section to configure the 

badge layout. 

 To change the badge display of recent products, select the 

available options in the badge field. You can choose to display 

the badge in NEW text or your own text by selecting the custom 

badge. 

 To change the badge display of sale products, select the 

available options in the sale field. You can choose to display the 

badge in SALE text or the amount of the discount. 

 NONE option means you disable the badge display.  

NOTE: Grouped product can only use the SALE text badge for sale 

products. 

Custom HTML Code 
To add HTML code in your shop homepage, scroll down to Shop Homepage section then input the code in the 

available box. 

  



Single Product 

To customize the display of single product page, navigate to Appearance > Customize > WooCommerce > 

Single Product. 

Single Product Layout 
There are 6 different layouts you can choose for general layout of the single product. Select the layout you like 

along with the sidebar layout option in the Layout section. 

 

In the Layout section you can also configure the product column number, enable/disable mobile sidebar, and 

enable/disable pagination of single product. 

NOTE: You can add sidebar in layout 4, 5, and 6. But you need to ensure that “Inhenrit from Customizer” 

option is selected for the product layout and sidebar layout in the Dahz Setting of the single product. 

 



Product Image Zoom & Lightbox Gallery 
In the Gallery section you can enable/disable lightbox gallery and mouse-over zoom for product image.

Product Summary Display 
In the Product Summary Position section, select the where you want to display the product description. You 

can also choose to show/hide the product brand in the product summary.

Sticky Add to Cart 
Select the position to display sticky add to cart button in single product within the Sticky Add to Cart section. 

To disable, simply choose the off option.

Tabs & Related Product Setting 
To change how each tab displayed in the product description, scroll 

down to the Tabs section. There are 4 different tab displays you can 

choose and the option to enable/disable review tab. 

To configure the related product section in the single product, go to 

Related section. 

 

  



Sale Page 

In Upscale, you can create a sale page simply by adding ?sale_products=true after the target link. If you want 

to create a menu for the page that shows all of your items with sale badge, use the custom link to add menu, 

input your shop page link, then add the code above after the link. For example: 

https//:yourwebsite.com/shop/?sale_products=true. 

 

Product Video 

 



 

You can insert a product video in the single product so that your customers can get more perspective about 

your product in action. Simply input the URL link of the video from Youtube, Twitter, or Instagram within Dahz 

Setting at the bottom when you add a new product.

 

Catalog Mode 

To enable or disable catalog mode, navigate to Appearance > Customize > WooCommerce > Catalog Mode. 

After enabling it, you can also hide the price. 

NOTE: If you can’t directly see your customization on the live customizer, you need to Save & Publish it first. 

 

  



Quickview 

 

Navigate to Appearance > Customize > Woocommerce > Quickview then change the setting to enable or 

disable quickview features. 

NOTE: If you can’t directly see your customization on the live customizer, you need to Save & Publish it first. 

 

 

 

 

 

 

 

 

 

 



Mini Cart 

There 4 options to show your cart: fullwidth, dropdown, sidebar, or display as link only. To customize the cart 

display, navigate to Appearance > Customize > Header > Cart. You can enable/disable to show the total price 

beside the cart display and the cart dropdown. If you need, you can input custom code for the cart display too. 

 
 

Direct Checkout 

 

Navigate to Appearance > Customize > WooCommerce > Direct Checkout to enable or disable direct checkout 

features in shop page, single product, and product quickview. You can also custom the text for direct checkout 

button. 

NOTE: If you can’t directly see your customization on the live customizer, you need to Save & Publish it first. 



Recently Viewed 

 

To enable the recently viewed feature on your site, go to Appearance > Customize > WooCommerce > 

Recently Viewed.

 

           

 

  



Promo Banner 

 

Promo banner appears at the very top of your site page. To enable and set up promo banner on your page, go 

to Appearance > Customize > General > Promo Banner. 

1. Enable the promo banner 

option. 

2. Enter banner text content. 

3. Select a background color or 

upload your own background 

image. 

4. Select your preferred option 

for background size, repeat, 

position, and attachment. 

5. Select a color for text content.  

6. Select the interval when you 

want the promo banner 

appears. 

7. Click Save & Publish button. 

NOTE: When setting up the promo 

banner, you can’t directly see it on the 

customizer. You need to Save & 

Publish it first. 

        

 

  



Wishlist 

Wishlist feature in Upscale is handled by YITH WooCommerce Wishlist plugin. When you install and activate 

the plugin, wishlist page is created automatically. If the page is not created, you need to create one by 

yourself.  

1. Navigate to Pages > Add New. 

2. Give it a title such Wishlist, then enter the shortcode [yith_wcwl_wishlist] in the content editor. 

 

 



3. Make sure default template is chosen as the template. 

 

4. Scroll down to customize the layout of the page in the Dahz Setting 

 

5. Click on Publish. 

6. Navigate to YITH Plugins > Wishlist and make sure the page created in the above step is selected in 

the Wishlist Page option. You can also customize the text setting within the section. 

NOTE: You can also change the wishlist page title style within Appearance > Customize > Header > Wishlist. 

 

  



Brand 

 

In Upscale you can showcase products based on their brands and also show brand text or logo on a single 

product page that will direct users to the brand page. To input the brand details, navigate to Products > Brand, 

then add a new brand with its details such as header image, page title layout, and brand logo. 

 

 

You can also create a new brand directly in the Brand section when you add a product, then set up the details 

later within Brand settings. 



NOTE: To show brand text or logo in a single product page, navigate to Appearance > Customize > 

WooCommerce > Single Product. To select a general page title layout, navigate to Appearance > Customize > 

WooCommerce > Shop. 

 

Filters 

Product filters is really useful to help your 

customers finding what they are looking for 

quickly. Shop filters use sidebars and widgets to 

filter the result of your product search. In Upscale 

you can leverage the sidebar to create product 

filters. 

To add product filters, navigate to Appearance > 

Customize > Widget, select the shop area, then 

add any filter widget. You can also set the filter 

from Appearance > Widgets from your WordPress 

dashboard. Drag and drop any filter widget into the 

shop area then configure the settings as you want. 

Account 

To customize the account display, navigate to Appearance > Customize > Header > Account. To set up your My 

Account page, head to Pages > All Pages then select a page named My Account. If you want to enable register 

option displayed on the header, head to WooCommerce > Settings, then check the box for ‘enable registration 

on the “My Account” page. 

 

  



Search 

 

Search Modal 

 
Search Form 

 

To customize the display of search box, navigate to Appearance > Customize > Header > WooCommerce 

Search. 

 

 

  



Size Guide 

 

 



 

 

Creating a predefined size guide is as easy as creating a new page or post. A size guide can be added to a 

product detail later, so you don’t have to create size guide in every post.  

1. On the sidebar menu of WordPress dashboard, select Size > Add New. 

2. Give a title such as ‘Women Tops Guide’, then assign it to a category (you can create a new one too). 

3. You can use Visual Composer editor or classic editor to create the size guide. 

To assign the size guide page on your single product page, scroll down to find Dahz Setting when creating or 

editing a product, then select the size page you have created in the Size Guide option. 

 

  



Blog 

 

Creating Blog Posts 

Upscale comes with 4 different post formats: standard, video, gallery, and audio. To create a blog post, from 

your WordPress dashboard go to Posts > Add New. You need to choose what format your post is from the 

‘Format’ box on the right side then insert the necessary info. 

Once you've decided your desired post format, enter your title, add your content where you can use any 
shortcode or HTML in the editing field, and remember to assign at least one category to your post. In the Dahz 
Setting at the bottom you can set the sidebar layout for post page, add a subtitle, and add an affiliate widget. 
Do not forget to assign a featured image to the post.  

After you’ve finished preparing your post, you can click Preview to see how your post will look once it is 
published onto your site. Click Publish to have it appear on your site, or click Save Draft to save your post as it 
is, though it is not published yet.  



 

Assign Blog Post Featured Image  

Setting up a featured image to your posts is very important, as the featured image is what the theme and 
other web functions use to visually represent the post in various situations. Featured image is a WordPress 
theme feature which supports the use of a representative image for posts, pages, related post areas, recent 
post widgets, featured area sliders, etc. 

To assign a featured image to existing posts, navigate to your post’s create or edit screen and look to the 
bottom-right of the screen. You’ll see a box titled ‘Featured Image’ where you can add your desired image. Be 
sure to click Update button when you’re finished.  
 
NOTE: Use landscape photos with 16:9 aspect ratio for the best result. 
 

Customize Blog Post Page 
To customize the appearance of a single post page, navigate to Appearance > Customize > Blog > Single Post. 

You can choose the layout to display feature image and enable elements in a single post. 

 

Blog Page Setup 

To display your blog posts, you need to create a blog page first  

1. Go to Pages > Add New 

2. Enter the title for the page such as ‘Blog’ then click on Publish button 

3. Follow the static page setting in this section. 



Featured Area 

 

On the blog page you can display a featured area which highlights some of your blog posts. There are 3 

different layouts of featured area to choose.  

 

 Make sure your posts have featured images. This is the image that the featured area will pull in 
represent your post. Also do not forget to assign the category as the posts to display are based on the 
category selected. 

 Next, navigate to Appearance > Customize > Blog > Featured Area, then enable the featured area and 
set it up such as selecting the layout and number of post to display. Click on Save & Publish button 
after. 

NOTE: To get the slug category, head to Posts > Categories, quick edit the category you want to input, then 

copy the slug. 



 

Customize Blog Page 
To change the layout of the blog page, head to Appearance > Customize > Blog > Blog Post then choose one of 

7 layout options.  

  

 

Archive Page 

 

Category Pages (which display all blog posts related to a particular category), Tag Pages (which display all blog 
posts related to a particular tag), Author Pages (which display all blog posts related to a particular author) are 
called Archive Page.  



To change the page layout of your archive page, head to Appearance > Customize > Blog > Archive Layout and 
choose one from 7 layout options. You can also choose the layout to show the page title. 

 

Blog Pagination 
Upscale has 2 styles of pagination for the blog section; number pagination and prev-next pagination. You can 
set different styles of pagination on your blogpost page and archive page.  

 To set pagination on your blogpost page, navigate to Appearance > Customize > Blog > Blog Post. 

 To set pagination on your archive page, navigate to Appearance > Customize > Blog > Archive Layout. 
 

Blog Sidebar 
You can enable or disable sidebar that will be displayed on the 

left or side area of your blog post page, blog page, and archive 

page. 

 To enable or disable sidebar on the blog post page, go to 

Appearance > Customize > Blog > Single Post and change 

the sidebar layout. For the sidebar layout, you can also 

choose it when creating a new post within Dahz Setting. 

 To enable or disable sidebar on the blog page, go to 

Appearance > Customize > Blog > Blog Post and change 

the sidebar layout. 

 To enable or disable sidebar on the archive pages, go to 

Appearance > Customize > Blog > Archive Layout and change the sidebar layout.  

Be sure to click save & publish button after. 

 

 

  



Portfolio 

 

Upscale includes a built-in custom post type for the portfolio, making it easier to share your works incredibly. 

Portfolio feature can be used after installing and activating Dahz Portfolio plugin. 

Creating Portfolio Posts 

To create a portfolio post, navigate to Portfolio > Add New. We recommend you to use Visual Composer in 

creating portfolio post. Click on the Backend Editor button to change WYSIWYG editor into Visual Composer 

builder. 

Scroll down to configure Dahz Setting then fill out the available field:  



 

 General Layout 

o Header Option: style option to display header of the post. 

o Portfolio Overlay Background Color: set the color of background image when hovering on 

post featured image in portfolio page. 

o Portfolio Overlay Text Color: set the color of title font when hovering on post featured image 

in portfolio page. 

 Portfolio 

o Short Description: to add a description of the collection. 

o Media URL Video: to add a video as the header of post. 

o Image Header: to add an image as the header of post. 

 Element 

o After Header: add HTML code to display content after header in portfolio post page. 

o Before Footer: add HTML code to display content before footer in portfolio post page. 

NOTE: if you choose a video as the header, you also need to assign an image that will appear on the prev/next 

post preview at the bottom of collection page. 

Assign Portfolio Featured Images  

In portfolio post, you can set 2 additional images with the featured image and a background image that will be 

displayed on portfolio archive page. All those images will be displayed in the portfolio page when you use 

layout 1 (Calista), but if you use other layouts, only the main featured image will be displayed. 

To assign a featured image to existing posts, navigate to your post’s create or edit screen and look to the 
bottom-right of the screen. You’ll see a box titled ‘Featured Image’ where you can add your desired image. Be 
sure to click Update button when you’re finished. 
 



Customize Portfolio Post Page 
To customize the appearance of a portfolio post page, navigate to Appearance > Customize > Portfolio > 

Single Portfolio Layout. You can choose the default header style to use in a single post page and 

enable/disable pagination. 

 

Portfolio Page Setup 

To display your portfolio posts, you need to create a portfolio page first as the portfolio archive page. 

1. Go to Pages > Add New 

2. Enter the title for the page such as ‘Portfolio’  

3. From the Template dropdown menu, choose Portfolio 

4. Click on Publish button 

Customize Portfolio Page 
To change the layout of the portfolio page, go to Appearance > Customize > Portfolio > Portfolio Layout then 

choose one from 5 layout options.  

 

Portfolio Pagination 
 For portfolio page, Upscale has 3 styles of pagination; prev-next pagination, infinite load with button, 

and infinite load scroll. To set pagination, navigate to Appearance > Customize > Portfolio > Portfolio 
Layout. 

 For portfolio post, the pagination option is only prev-next, which you can enable/disable within 
Appearance > Customize > Portfolio > Single Portfolio Layout. 

 
 
 

  



Social Account 

 To set up links to your social account, add the URL of your account in Appearance > Theme Option > 

Social Account.  

 To change the order of social icon displays, you can drag and drop the account below the Social 

Account form. 

 To display your social icon on the top bar or footer area, you can drag and drop Social Icon element in 

header or footer builder.  

 If you need to change the display of social icon, you can go to Appearance > Customize > Header > 

Social Icon and Appearance > Customize > Footer > Subfooter.  

 

 

Instagram OAuth 

To set up Instagram Custom Feed or Filter Latest shortcode, you have to authorize your Instagram account first 

within Appearance > Theme Option > Social Account > OAuth. 

1. Go to https://www.instagram.com/developer/ and click the Register Your Application button. 

https://www.instagram.com/developer/


 
2. Fill out the field and click Sign Up, you’ll be redirected to the previous page. 

3. Click the Manage Client button on the top bar then click Register a New Client button. 

4. Fill the application name, description, company name, website URL, valid redirect URI, and contact email. 

NOTE: Valid redirect URI can be found in the Appearance > Theme Option > Social Account > OAUTH from 

your WordPress dashboard. 

 



 
 

 

5. After that, your client ID will be generated. Click the Manage button. 

 
6. Go to the Security tab then uncheck the ‘Disable implicit OAuth’ box. 



 
 

7. Next, simply copy the client ID then paste it into the available field in the Theme Option > Social Account > 

OAUTH 

 
 



 

 

 
 

 

8. After fill in the Instagram username and app ID, click Save Option button. Leave the access token field 

blank for now. 

9. Click the ‘Authorize Your Instagram Account’ link below the access token field 

10. You will need to authorize this app by signing in to your Instagram. Hit the Authorize button 

 
 

11. Go back to Theme Option > Social Account > OAUTH. Copy the token link from your URL address (the 

number after ‘token=’ then paste it into the access token field. 



 

12. Save options. 

  



Social Sharing Option 

You can add share buttons on a single post, single page, and 

portfolio share by enabling the option from Appearance > 

Customize > General > Share. The available sharing buttons 

are for Facebook, Twitter, Pinterest, and email. 

  

 

 

  



Setup Newsletter Signup Form 

Upscale comes with MailChimp for WordPress plugin to create newsletter signup form. The signup form can 

be displayed in the widget area and newsletter pop-up of your website. To add a MailChimp newsletter form, 

you need to create a MailChimp Account first if you don’t have one. Install and activate the plugin, and then 

set up your signup form. 

MailChimp Setting 

1. After installing and activating the plugin, go to MailChimp for WP > Mailchimp section from your 

dashboard. 

2. Add your MailChimp API key (use Get your API key here link to obtain your key) then click Save 

Changes. 

 
3. Go to MailChimp for WP > Forms, check your list for ‘Lists this form subscribes to’ option to set which 

list will be used for subscription on MailChimp. 

4. Customize the form to your liking, then click Save Changes. 

NOTE: You may use the field generator for the easiest way in creating form 

5. Copy the shortcode at the bottom of form setting to display this form inside a post, page or text 

widget; next we will try to create the form in the widget area.  

 

 
 

https://mailchimp.com/


6. Go to Appearance > Customize > Widget. 

7. Choose an available widget area to input the form, then add ‘MailChimp Sign-Up Form’ widget into it. 

8. Paste the shortcode in the box. 

9. Hit the save & publish button.  

 

Pop-up Setting 

 

After setting up the MailChimp form, you can use the shortcode to create pop-up signup form. 

1. Go to Appearance > Customize > General > Newsletter. 

2. Enable the newsletter pop-up option. 

3. Paste the MailChimp shortcode in the Newsletter Form. 

4. Fill in the heading and text for the pop-up form. 

5. Select the interval when you want the pop-up form appears. 

6. Upload images for the pop-up form; you can upload up to 3 images for the pop-up. 

7. Click Save & Publish. 

NOTE: If you can’t directly see your customization on the live customizer, you need to Save & Publish it first. 

 

  



Theme Customization 

Backup & Restore Theme Option Setting 

WordPress database is very fragile, so you need to put an extra effort to keep your data safe. To prevent any 

data loss we’ve added an export/import feature for your theme option. To backup or restore your setting, 

please go to Appearance > Theme Option > Export Import Setting. 

NOTE:  

- Reset All button will erase all of your customization so that your theme will be like the first time you install 

it. 

- Please always backup your setting before you add/update plugins or theme to avoid data loss. Periodic 

backup is recommended. 

 

 

 

 

 

 

 



 

Child Theme 

When you update the theme, any changes you've made to css and php files will be gone. To avoid re-applying 

your changes after updating, you can use child theme. 

A child theme is a theme that inherits the functionality and styling of another theme, called the parent theme. 

Child themes are the recommended way of modifying an existing theme as the changes in it won’t be affected 

by the updates. We include a child theme package ready that you can get within the main download folder 

named upscale-child. Upload the package after installing the theme. 

 

Color Styling 

To customize the color of your website, please navigate to Appearance > Customize > Color. There you can 

customize color elements of your website within three sections: general, button, and shop. 

General 
In the General section, you can customize the color style of website main elements such as heading 

 Main accent color: the color for the link elements such as categories and social icons 

 Body text color: the color for body text 

 Heading text color: the color for heading 

 Extra color: the color for breadcrumbs, post meta, author name and comment info 

 Widget title color: the color for widget title which can be seen on the sidebar or footer area 

 Border color: the color for border line such as separator line in the widget 

      



Button 
In the Button section you can customize the button color of each style on your site. 

 Button solid: the color for button solid style, such as the Submit button on comment section or 

Checkout button 

 Button outline: the color for button outline style, such as View Cart button. You can change the color 

based on the header transparent. If you want to custom the general button outline (no transparent 

header), custom the button outline dark section. 

NOTE: You can also set up the button radius within this section. 

     

Shop 
In the Shop section you can customize the color style of shop elements such as notification text or product 

badge. 

 Success color: the color for success notification (ex: when you successfully add a product to cart) 

 Info color: the color element for info notification (ex: the notification in the download section of My 

Account page) 

 Alert color: the color element for alert notification (ex: when you wrongly input coupon code in the 

cart/checkout page)  

 New color: the color element for ‘new’ product badge 

 Sale color: the color element for ‘sale’ product badge 

 Star color: the color element for star ratings 



     

 

Typography 

Fonts in Upscale are customizable. Everything you need to adjust your website fonts can be 

found in Appearance > Customize > Typography > Source Font. Select the source of the font you use, either 

Google Font or Adobe Typekit. 

 Family Font 1: applied for heading, widget title, and share text. 

 Family Font 2: applied for body elements, such as body text and post meta. 

 Variant: font weight. 

 Subset: alphabet type. 

For main navigation, header menu, dropdown menu, and button, you choose which font to use between 

family font 1 and 2.



    

 

 

Breadcrumbs 

 

You can enable/disable breadcrumbs altogether from Appearance > Customize > General > Breadcrumbs.

 
 
 
 



Page Transitions 

To enable and adjust transitions type on your website, go to Appearance > Customize > General > Transitions. 

NOTE: If you can’t directly see your customization on the live customizer, you need to Save & Publish it first. 

General Layout 

To customize the general layout of your website, navigate to Appearance > Customize > General > Layout. 

There you can customize the layout of your website within three layout to choose: fullwidth, boxed, and 

framed. 

 

 

      

  



Custom Code 

With Upscale you can easily add custom code to your 

website. Simply head to Appearance > Customize > General 

> Custom Code, then you will see editor buttons for: 

 Custom CSS: Add some CSS by adding it to this 

editor. 

 Custom Javascript: Add JavaScript and/or analytics 

code, any code that you add here will be moved to 

the footer. 

 

Google Analytics 
To add Google Analytics, head to Appearance > Customize > 

General > Global, the scroll down to find the Google Analytic 

ID box.

 

  



Translating Upscale 

1. Navigate to Plugins > Add New on your WordPress dashboard, then search for Loco Translate. Install 

and activate the plugin. 

 

 

2. After activating, go to Loco Translate > Themes from the sidebar menu, then select the theme you 

want to translate.  

3. Choose the Advanced tab, then edit the File prefix box. Leave it blank and click Save config button. 

 

 

 

 



4. Choose the Overview tab, then click (+) New Language.  

 
 

5. Select the WordPress language option and the language you want to translate on the dropdown list. 

Make sure the location you choose is Author, then click Start translating button. 

 

 
 

 

6. You may start your translation now. You can select the text inside the theme you want to translate on 

the Source Text list, then add the translation on the available translation area.  

For example, if you want to translate word ‘recommended’, you have to find and select it first on the 

Source Text list then add the translated text inside the translation box. 

 

7. Click Save button again as soon as you’re done translating, then click Sync. 



 
 

 
 

8. The last step is to activate and use the new language. Go to Settings > General from the sidebar menu. 

On the bottom of the page, change the language in the Site Language options, then click Save 

Changes. 



 

Done! The default language both on your WordPress dashboard and on your site has changed. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Denouement 
Once again, thank you for purchasing Upscale! 

If you still have a question that this documentation can’t resolve, drop us a line at our support forum and we'll 

do our very best to assist you. We wish you all the best and we truly hope Upscale can help you create an 

eCommerce website you’ve been dreaming of. Cheers! 

file:///D:/support.daffyhazan.com
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